Bug 111719 - crash while deleting and creating a load of files
crash while deleting and creating a load of files
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 05:43 EST by Bastien Nocera
Modified: 2014-08-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 09:17:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2003-12-09 05:43:32 EST
Backtrace from the segfault:

#0  0xb75ebc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0xb7303963 in __xstat64@GLIBC_2.1 () from /lib/tls/libc.so.6
#2  0x081acd13 in sys_stat (fname=0x0, sbuf=0xbfffba50) at stat.h:359
#3  0x080ab634 in get_lanman2_dir_entry (conn=0x83c4650, inbuf=0xb6f85008,
   outbuf=0xb6f64008, path_mask=0xbfffae50 "ko120841.dll", dirtype=22,
   info_level=260, requires_resume_key=1, dont_descend=0,
ppdata=0xbfffbb38,
   base_data=0x84af270 "", space_remaining=16384, out_of_space=0xbfffbb3c,
   got_exact_match=0xbfffbb40, last_name_off=0x0) at smbd/trans2.c:563
#4  0x080ac07c in call_trans2findfirst (conn=0x83c4650,
inbuf=0xb6f85008 "",
   outbuf=0xb6f64008 "", bufsize=0, pparams=0x0, total_params=58,
   ppdata=0xbfffc428, total_data=0) at smbd/trans2.c:1045
#5  0x080b3e4c in reply_trans2 (conn=0x83c4650, inbuf=0xb6f85008 "",
   outbuf=0xb6f64008 "", length=130, bufsize=131072) at smbd/trans2.c:3593
#6  0x080c7286 in switch_message (type=50, inbuf=0xb6f85008 "",
   outbuf=0xb6f64008 "", size=130, bufsize=0) at smbd/process.c:767
#7  0x080c7459 in construct_reply (inbuf=0xb6f85008 "",
outbuf=0xb6f64008 "",
   size=130, bufsize=131072) at smbd/process.c:797
#8  0x080c766f in process_smb (inbuf=0xb6f85008 "", outbuf=0xb6f64008 "")
   at smbd/process.c:897
#9  0x080c82a7 in smbd_process () at smbd/process.c:1323
#10 0x0822407f in main (argc=0, argv=0xbfffc704) at smbd/server.c:887
Comment 2 Bastien Nocera 2003-12-09 05:48:20 EST
See for equivalent FC bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=110892
and upstream bug:
https://bugzilla.samba.org/show_bug.cgi?id=809
Comment 3 Jay Fenlason 2004-01-17 00:02:26 EST
I've put RPMs of samba-3.0.2rc1 on 
http://people.redhat.com/fenlason/.samba .  Can you try them and see if 
they resolve your problem.  Note that these are un-qa'd packages of a 
release that is not intended for production use.  If they solve your 
problem, I will attempt to get samba-3.0.2 included in the next quarterly 
update of Red Hat Enterprise Linux 3. 
Comment 4 Bastien Nocera 2004-01-26 07:37:47 EST
Jay, this particular problem seems to be fixed in your updated
packages. Another (perhaps related, maybe memory corruption of some
kind) problem appeared, but that's another bug.
Comment 5 Bastien Nocera 2004-01-26 09:17:10 EST
And closed.

Note You need to log in before you can comment on or make changes to this bug.