Bug 111739 - Very slow NFS write performance on ia64
Very slow NFS write performance on ia64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
ia64 Linux
high Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 11:46 EST by Michael Blandford
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 12:36:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Blandford 2003-12-09 11:46:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
NFS write performance on ia64 is 5-7 times worse than ia32.

Test boxes: ia32 - 1Ghz P3 x330, ia64 - 900Mhz RX6000, ia64 - 1.3Ghz
RX6000

All tests are done using the same nfs fileserver.  Tests were done
sequentially.  Fileserver and clients had no load at the time.

This is easily reproduceable

cd /nfs/<somewhere>

2.4.9 � ia32

ia32> time dd if=/dev/zero of=ddtest bs=1024 count=500000
500000+0 records in
500000+0 records out
0.270u 4.190s 0:53.82 8.2%      0+0k 0+0io 115pf+0w

2.4.20 � ia32
ia32> time dd if=/dev/zero of=ddtest bs=1024 count=500000
500000+0 records in
500000+0 records out
0.300u 4.610s 0:48.13 10.2%     0+0k 0+0io 115pf+0w

2.4.18 � ia64 - McKinely
ia64> time dd if=/dev/zero of=ddtest bs=1024 count=500000
500000+0 records in
500000+0 records out
0.940u 9.125s 7:00.36 2.3%      0+0k 0+0io 73pf+0w

2.4.18 � ia64 - Madison
ia64>  time dd if=/dev/zero of=ddtest bs=1024 count=500000
500000+0 records in
500000+0 records out
0.247u 8.161s 5:30.27 2.5%      0+0k 0+0io 73pf+0w


Version-Release number of selected component (if applicable):
2.4.18-e.37smp

How reproducible:
Always

Steps to Reproduce:
1. In the description field
2.
3.
    

Actual Results:  ia64 shows at least 5x performace loss compared to ia32.

Expected Results:  Comparable results between the platforms would be
expected.

Additional info:
Comment 1 Michael Blandford 2003-12-29 12:33:40 EST
It seems to be related to the packet size.  >= 16k packets yield 
comparable performance to ia32.

Should the kernel ( or autofs ) default to something more reasonable 
on ia64?

Comment 2 Arjan van de Ven 2003-12-29 12:35:33 EST
kernel has no default; mount sets a default fwiw.
Comment 3 Steve Dickson 2004-01-14 12:36:35 EST
The problem is you are doing sync writes instead of async writes 
since the page size (16k)(on an ia64) is larger that server's 
write size which is typically 8k.



Note You need to log in before you can comment on or make changes to this bug.