Bug 111757 - pdksh does not handle io > 2GB
pdksh does not handle io > 2GB
Status: CLOSED DUPLICATE of bug 76307
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: pdksh (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Depends On:
  Show dependency treegraph
Reported: 2003-12-09 12:46 EST by Carson Harding
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Carson Harding 2003-12-09 12:46:53 EST
Description of problem:

pdksh will not redirect from or to files > 2GB in size

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. ksh
2. dd if=/dev/zero of=testfile.in bs=4096 count=1000000
3. cat < testfile.in > testfile.out
Actual results:

ksh: cannot open testfile.in: File too large

Expected results:

copies data

Additional info:
Comment 1 Carson Harding 2003-12-09 12:49:51 EST
Seems to work ok if compiled with 
Comment 3 Florian La Roche 2003-12-17 06:01:22 EST
RHEL AS 2.1 Update 3 should contain a fix for this item. I have also
copied the src.rpm onto http://people.redhat.com/laroche/pdksh*.

Please update this bugzilla if that rpm does not work for you.


Florian La Roche
Comment 4 Florian La Roche 2003-12-31 02:14:03 EST
Closing as dup from #76307 and a fixed rpm should be already released.


Florian La Roche

*** This bug has been marked as a duplicate of 76307 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.