Bug 111765 - (supertoaster2) Error On Username when trying to register system
Error On Username when trying to register system
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 15:33 EST by Timothy Cook
Modified: 2007-10-23 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 17:09:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Cook 2003-12-09 15:33:02 EST
Description of problem:


Version-Release number of selected component (if applicable):

Don't know?

How reproducible:

I do not think you can reproduce the problem.

Steps to Reproduce:
1. I tried RHN and kept causing an error, on registering username,
also it kept hanging on privacy and aggreements page.

2. I then created an account with the linux machine on the Red Hat
Website and logged onto Red Hat Networks. 

3. Informed me it has no system status for my machine, which is
correct, because I can't register it, because it keeps failing with
the username.

4. I then re-tried to register the sysem with Red Hat Networks
connection wizard, no joy!!!
  
Actual results:

Error with username


Expected results:

Able To Register System with RHN

Additional info:
Comment 1 Timothy Cook 2003-12-09 15:43:30 EST
Exception type SSL.Error

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 447, in
refresh
    self.model.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line
264, in refresh
    self.__rpc_server__.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpc.py", line 84,
in refresh
    status = server.applet.poll_status()
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in
_request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 130,
in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 614,
in send_http
    headers=self.headers)
  File "/usr/lib/python2.2/httplib.py", line 701, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.2/httplib.py", line 723, in _send_request
    self.endheaders()
  File "/usr/lib/python2.2/httplib.py", line 695, in endheaders
    self._send_output()
  File "/usr/lib/python2.2/httplib.py", line 581, in _send_output
    self.send(msg)
  File "/usr/lib/python2.2/httplib.py", line 560, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 191, in write
    sent = self._connection.send(data)
Error: [('SSL routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate
verify
Comment 2 Josef Komenda 2003-12-09 17:21:00 EST
What username are you trying to register? 
What version of Red Hat Linux are you using? 
What is your version of up2date? (rpm -q up2date)

For the SSL, see: https://rhn.redhat.com/help/latest-up2date.pxt

Comment 3 Timothy Cook 2003-12-22 12:09:55 EST
My username is supertoaster2. It just keeps saying it has a problem 
with my username?
Comment 4 Timothy Cook 2003-12-22 12:10:48 EST
My Linux is a Red Hat 9, I will check the up2date version later, if 
that okay.
Comment 5 Mihai Ibanescu 2004-05-28 21:39:29 EDT
Wow, old bug that slipped.
This looks like:
either an older up2date version
a problem with the system's clock.

Can you please download the latest up2date (the one that has the
correct ssl certificates?)
Comment 6 Todd Warner 2005-09-23 17:09:33 EDT
No response in 1 year. Closing.

Note You need to log in before you can comment on or make changes to this bug.