Bug 1117842 - Update epel-7 mock configs to use centos.org mirrors
Summary: Update epel-7 mock configs to use centos.org mirrors
Keywords:
Status: CLOSED DUPLICATE of bug 1108402
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1118389 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 13:37 UTC by James Laska
Modified: 2014-07-14 12:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-14 12:28:21 UTC


Attachments (Terms of Use)
0001-Update-epel-6-mirrorlist-URLs-to-use-centos.org.patch (1.54 KB, patch)
2014-07-09 13:37 UTC, James Laska
no flags Details | Diff

Description James Laska 2014-07-09 13:37:18 UTC
Created attachment 916774 [details]
0001-Update-epel-6-mirrorlist-URLs-to-use-centos.org.patch

Description of problem:

The current version of mock includes a epel-7 mirrorlist that results in a 404.  I believe the mock epel-7-* config files can be updated to use the centos mirrors.  This works, and appears to match the practice used in the epel-6-* configs.

See attached patch that replicates the epel-6 mirrorlist configuration into epel-7.

Version-Release number of selected component (if applicable):
* mock-1.1.39-1.el6.noarch


How reproducible:


Steps to Reproduce:
1. mock -r epel-7-x86_64 --init

Actual results:

 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-7-x86_64/root/', 'update']
http://ftp.redhat.com/pub/redhat/rhel/rc/7/Server/x86_64/os/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: el. Please verify its path and try again


Expected results:

No failure.

Additional info:

Comment 1 Nikolas J. Britton 2014-07-10 15:06:54 UTC
*** Bug 1118389 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Suchý 2014-07-14 12:28:21 UTC
Already fixed in bug 1108402.

*** This bug has been marked as a duplicate of bug 1108402 ***


Note You need to log in before you can comment on or make changes to this bug.