Bug 1117885 - Rubygem-Staypuft: Deployment gets stuck on 60% installing controller - puppet error.
Summary: Rubygem-Staypuft: Deployment gets stuck on 60% installing controller - puppe...
Keywords:
Status: CLOSED DUPLICATE of bug 1117844
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 15:17 UTC by Alexander Chuzhoy
Modified: 2014-07-09 15:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-09 15:21:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages file from the controller that has the pupper errors. (651.39 KB, text/plain)
2014-07-09 15:17 UTC, Alexander Chuzhoy
no flags Details

Description Alexander Chuzhoy 2014-07-09 15:17:32 UTC
Created attachment 916831 [details]
/var/log/messages file from the controller that has the pupper errors.

Rubygem-Staypuft:  Deployment gets stuck on 60% installing controller - puppet error.
Environment:

Steps to reproduce: 
1. Install rhel-osp-installer
2. Create a deployment of 3 hosts (Nova controller + 2 compute nodes)

Result:
The deployment gets stuck on 60% installing the controller.
This happens due to the following puppet error:
Could not retrieve catalog from remote server: Error 400 on SERVER: str2bool_i(): Unknown type of boolean given at /etc/puppet/environments/production/modules/quickstack/manifests/controller_common.pp:342 on node <node name>

Comment 1 Omri Hochman 2014-07-09 15:21:30 UTC

*** This bug has been marked as a duplicate of bug 1117844 ***


Note You need to log in before you can comment on or make changes to this bug.