Bug 111792 - hwbrowser does not show libata SATA drives
hwbrowser does not show libata SATA drives
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hwbrowser (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 23:14 EST by Jon Smirl
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-17 11:18:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows kernel finding SATA drive (16.16 KB, text/plain)
2003-12-15 22:38 EST, Jon Smirl
no flags Details

  None (edit)
Description Jon Smirl 2003-12-09 23:14:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
hwbrowser does not show libata SATA drives. 
They're just missing from the harddrive tab.
My other drives are there.

Version-Release number of selected component (if applicable):
hwbrowser-0.12-1

How reproducible:
Always

Steps to Reproduce:
1. Install SATA drive
2. configure kernel to use libata instead of IDE
3. look for it in hwbrowser
    

Additional info:
Comment 1 Brent Fox 2003-12-11 12:42:46 EST
Are you running hwbrowser as root or not?  For some reason, I see the
drives if I run it as root but not as a regular user.  I wonder why
that is...
Comment 2 Brent Fox 2003-12-11 12:45:57 EST
Ah, it is the call to parted.PedDevice.get() that is trying to access
/dev/sda, which is not allowed unless you are root.  
Comment 3 Brent Fox 2003-12-11 14:02:45 EST
After talking with some of the other developers, we should make
hwbrowser require the root password in order to run.  
Comment 4 Brent Fox 2003-12-11 18:11:18 EST
Oh wait, it already requires root priviledges to run.  

Try this:  As root, run 'kudzu --probe --class=HD' and attach the
output to this report.
Comment 5 Jon Smirl 2003-12-15 22:37:52 EST
[root@smirl jonsmirl]# /usr/sbin/kudzu --probe --class=HD
-
class: HD
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "IC35L060AVV207-0"
physical: 16383/16/63
logical: 16383/255/63
[root@smirl jonsmirl]#
Comment 6 Jon Smirl 2003-12-15 22:38:54 EST
Created attachment 96550 [details]
Shows kernel finding SATA drive
Comment 7 Jon Smirl 2003-12-15 22:40:48 EST
sata drive is not in /etc/sysconfig/hwconfig
Comment 8 Jon Smirl 2003-12-16 15:10:27 EST
Note that there are two ways to hook a SATA drive up in the kernel.
One way is via the IDE drivers. That way works with hwbrowser. The
other is the brand new libata scheme which works via the SCSI
subsystem. That one doesn't work.

You want to use the libata method; it works at full speed UDMA150/133,
the IDE scheme only works at UDMA33.

I definitely have a functioning /dev/sda device.

You might want to have a kernel person look at this bug too:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=108001
Comment 9 Jon Smirl 2003-12-16 16:33:42 EST
This is only broken in a 2.6 kernel.

2.4 works. Although I couldn't tell that until today since 2.4
wouldn't boot on my SATA drive until today. Dell issued BIOS patch
that fixes boot issue.

Comment 10 Matt Hansen 2004-01-15 23:17:11 EST
I am experiencing the same problem, but with my FDD. hwbrowser does
not show it and there is no entry in /etc/sysconfig/hwconf. The drive
works fine and the floppy module is loading on boot.

Should I file a new report or just leave this comment as an addendum
to this bug report?
Comment 11 Brent Fox 2004-03-09 12:07:35 EST
Matt: file a new report.
Comment 12 Jeremy Katz 2004-03-12 14:56:14 EST
Works for me with ICH5 SATA and current rawhide kernels...  do you
still see this with newer kernels?
Comment 13 Jon Smirl 2004-03-12 15:14:34 EST
Still not there on up2date FC1. Right now I am running 2.6 kernel on
FC1. It appears if I use the IDE driver.
Comment 14 Brent Fox 2004-06-17 11:18:45 EDT
This works fine for me with FC2.  Please reopen this bug report if the
behavior persists in FC2 on your machine.

Note You need to log in before you can comment on or make changes to this bug.