Bug 111793 - perl5.8.0 has SIGCHLD set to SIG_IGN but calls wait().
perl5.8.0 has SIGCHLD set to SIG_IGN but calls wait().
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-10 00:14 EST by Seng Oon
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: ALL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 16:16:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Seng Oon 2003-12-10 00:14:18 EST
Description of problem:
My system report this every hours:
Dec 10 13:01:01 NS1 kernel: application bug: perl5.8.0(25092) has 
SIGCHLD set to SIG_IGN but calls wait().
Dec 10 13:01:01 NS1 kernel: (see the NOTES section of 'man 2 wait'). 
Workaround activated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Endre Nagy 2004-02-14 13:31:16 EST
Reproducible with current openwebmail:
/var/www/cgi-bin/openwebmail/openwebmail-tool.pl -n -a -q
^C

The result will be in /var/log/messages.
Comment 2 Charlie Brady 2005-05-19 13:54:10 EDT
This is a duplicate of 117333, which has been closed notabug (bug is reportedly
in openwebmail-tool.pl).
Comment 3 Jason Vas Dias 2005-11-10 16:16:37 EST
Sorry for the long delay in processing this bug -
it is fixed in all current Red Hat perl releases. 

Note You need to log in before you can comment on or make changes to this bug.