Bug 1117930 - Rubygem-Staypuft: error rendering the Kickstart RHEL default template for compute nodes installed in parallel.
Summary: Rubygem-Staypuft: error rendering the Kickstart RHEL default template for co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 16:26 UTC by Alexander Chuzhoy
Modified: 2014-09-08 05:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:35:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
production.log from the staypuft host. (796.02 KB, text/x-log)
2014-07-09 16:26 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 0 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Alexander Chuzhoy 2014-07-09 16:26:08 UTC
Created attachment 916878 [details]
production.log from the staypuft host.

Rubygem-Staypuft:  error rendering the Kickstart RHEL default template for compute nodes installed in parallel

Environment: rhel-osp-installer-0.1.0-2.el6ost.noarch

1. Install rhel-osp-installer
2. Create a non HA deployment of 3 hosts (1 nova controller + 2 compute nodes)
3. Fix everything in puppet (if needed) for the controller installation to complete 100% and resume the deploymet (if needed) to make sure the compute nodes are starting to install.

Result:
The deployment of the compute nodes gets stuck on 15%. The nodes aren't able to fetch the kickstart file. From the foreman UI I get the following when I try to review the provision template for the compute nodes:
"There was an error rendering the Kickstart RHEL default template: (<unknown>): mapping values are not allowed in this context at line 2 column 19"

Note: at the same time reviewing the provision template for the controller shows a valid kickstart file and the controller was in fact provisioned.


Expected result:
The deployment of the compute nodes should complete with no issues.

Comment 2 Alexander Chuzhoy 2014-07-09 17:57:48 UTC
Getting the following upon clicking on the yaml button for that node:
Error
(<unknown>): mapping values are not allowed in this context at line 2 column 19

If you feel this is an error with Foreman itself, please open a new issue with Foreman ticketing system, You would probably need to attach the Full trace and relevant log entries.
Psych::SyntaxError
(<unknown>): mapping values are not allowed in this context at line 2 column 19
app/models/lookup_key.rb:237:in `rescue in load_yaml_or_json'
app/models/lookup_key.rb:234:in `load_yaml_or_json'
app/models/lookup_key.rb:251:in `cast_value_hash'
app/services/safe_render.rb:19:in `parse'
app/services/classification/base.rb:64:in `value_of_key'
app/services/classification/class_param.rb:13:in `block (2 levels) in enc'
app/services/classification/class_param.rb:12:in `each'
app/services/classification/class_param.rb:12:in `block in enc'
app/services/classification/class_param.rb:9:in `enc'
app/models/host/managed.rb:773:in `lookup_keys_class_params'
app/models/host/managed.rb:347:in `info'
app/controllers/hosts_controller.rb:178:in `block (2 levels) in externalNodes'
app/controllers/hosts_controller.rb:177:in `externalNodes'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

Comment 3 Hugh Brock 2014-07-10 00:58:04 UTC
We found a fix for this tonight, it has been pushed to master, see poodle tomorrow for new RPM containing rubygem-staypuft-0.1.8.4. Will update here when RPM is available.

Comment 4 Hugh Brock 2014-07-10 14:25:42 UTC
should be fixed in YAP today

Comment 7 Alexander Chuzhoy 2014-07-21 15:02:44 UTC
Verified: rhel-osp-installer-0.1.1-1.el6ost.noarch

The reported issues don't reproduce.

Comment 8 errata-xmlrpc 2014-08-04 18:35:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.