Bug 1117940 - JBWEB000065: HTTP Status 500 - java.util.MissingResourceException: Can't find bundle for base name org.jboss.dashboard.login.messages, locale en
Summary: JBWEB000065: HTTP Status 500 - java.util.MissingResourceException: Can't find...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Dashboard Builder
Version: 6.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ER1
: 6.1.0
Assignee: Van Halbert
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 16:34 UTC by Hugo Guerrero
Modified: 2016-02-10 08:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Users could not access the dashboard at http://localhost:8080/dashboard as they would counter an HTTP Status 500 - java.util.MissingResourceException. This was corrected by a version update. As a result, users can now acess the dashboard.
Clone Of:
Environment:
Last Closed: 2016-02-10 08:50:44 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDSHB-7 Blocker Closed HTTP Status 500 - java.util.MissingResourceException: Can't find bundle for base name org.jboss.dashboard.login.messages... 2015-04-01 21:53:58 UTC

Description Hugo Guerrero 2014-07-09 16:34:57 UTC
Description of problem:

Navigation to http://localhost:8080/dashboard after a clean install of dv-6.1.0-DR1 causes a http 500 error

Version-Release number of selected component (if applicable):

dv-6.1.0-DR1

How reproducible:

Clean install of DV

Steps to Reproduce:
1. Install DV
2. Navigate to dashboard login page
3.

Actual results:

Http 500 Error

Expected results:

Login page

Additional info:

Caused by: java.util.MissingResourceException: Can't find bundle for base name org.jboss.dashboard.login.messages, locale en
	at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1539) [rt.jar:1.6.0_30]
	at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1278) [rt.jar:1.6.0_30]
	at java.util.ResourceBundle.getBundle(ResourceBundle.java:804) [rt.jar:1.6.0_30]
	at org.apache.jsp.login_jsp._jspService(login_jsp.java:85)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:69) [jbossweb-7.4.2.Final-redhat-1.jar:7.4.2.Final-redhat-1]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [jboss-servlet-api_3.0_spec-1.0.2.Final-redhat-1.jar:1.0.2.Final-redhat-1]
	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:365) [jbossweb-7.4.2.Final-redhat-1.jar:7.4.2.Final-redhat-1]
	... 21 more


Repaired if changing the login.jsp in line 37:

            ResourceBundle i18nBundle = ResourceBundle.getBundle("org.jboss.dashboard.login.messages", LocaleManager.currentLocale());

to 

            ResourceBundle i18nBundle = ResourceBundle.getBundle("org.jboss.dashboard.login", LocaleManager.currentLocale());


and restart.

Comment 3 JBoss JIRA Server 2015-04-01 21:53:58 UTC
Van Halbert <vhalbert@jboss.org> updated the status of jira TEIIDDSHB-7 to Closed


Note You need to log in before you can comment on or make changes to this bug.