Bug 1117991 - The "kinit" command is in a constant loop of initially changing the user password.
Summary: The "kinit" command is in a constant loop of initially changing the user pass...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 19:11 UTC by Bill Sanford
Modified: 2014-08-18 19:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 13:59:29 UTC


Attachments (Terms of Use)
Pastebin contents from Description (3.66 KB, text/plain)
2014-07-21 14:52 UTC, Martin Kosek
no flags Details

Description Bill Sanford 2014-07-09 19:11:51 UTC
Description of problem:
In http://pastebin.test.redhat.com/220582 you can add user, modify the password but the first kinit of the user results in an error message "kinit: Password has expired while getting initial credentials"

The original install account with the original first added user work fine. Every other user does not behave like it should.

When you do a "kinit" the password changes.

[root@spiceipa ~]# kinit test
Password for test@SPICE.ML2.ENG.BOS.REDHAT.COM: 
Password expired.  You must change it now.
Enter new password: 
Enter it again: 
kinit: Password has expired while getting initial credentials
[root@spiceipa ~]# kinit test
Password for test@SPICE.ML2.ENG.BOS.REDHAT.COM: 
Password expired.  You must change it now.
Enter new password: 
Enter it again: 
kinit: Password has expired while getting initial credentials
[root@spiceipa ~]# 

It is in a constant loop of changing the password that was changed.

Version-Release number of selected component (if applicable):
RHEL 6.5.

ipa-admintools-3.0.0-37.el6.x86_64
libipa_hbac-1.9.2-129.el6_5.4.x86_64
ipa-server-selinux-3.0.0-37.el6.x86_64
ipa-client-3.0.0-37.el6.x86_64
python-iniparse-0.3.1-2.1.el6.noarch
ipa-pki-ca-theme-9.0.3-7.el6.noarch
ipa-pki-common-theme-9.0.3-7.el6.noarch
libipa_hbac-python-1.9.2-129.el6_5.4.x86_64
ipa-server-3.0.0-37.el6.x86_64
ipa-python-3.0.0-37.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dmitri Pal 2014-07-15 13:09:47 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4437

Comment 2 Martin Kosek 2014-07-21 14:52:50 UTC
Created attachment 919655 [details]
Pastebin contents from Description

Comment 3 Martin Kosek 2014-07-21 14:55:46 UTC
We need more data to assess. Could you please kindly:

1) Show your password policy

$ ipa pwpolicy-show

2) Show a FULL user entry BEFORE and AFTER the kinit with initial password change

$ ipa user-add test
$ ipa user-mod test --password

$ ipa user-show test --all --raw

$ kinit test
... I assume the fail will happen again

$ ipa user-show test --all --raw

Comment 4 Martin Kosek 2014-07-29 14:42:21 UTC
Hello, any luck retrieving the data? Without them, we cannot continue with investigation.

Comment 5 Martin Kosek 2014-08-04 13:59:29 UTC
I assume this is caused by a too high Max lifetime in pwpolicy-show (see Bug 891977). However, without additional asked in Comment 3, it cannot be proven. Closing the bug until the data is provided.

Comment 6 Bill Sanford 2014-08-18 19:48:35 UTC
There was something in the install that exacerbated this bug. I will reopen if I see this again.


Note You need to log in before you can comment on or make changes to this bug.