Bug 1118015 - Receive HTTP 200 after creating operating system, not HTTP 201
Summary: Receive HTTP 200 after creating operating system, not HTTP 201
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1118894 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 20:47 UTC by jaudet
Modified: 2017-03-14 17:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 17:10:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6701 None None None 2016-04-22 16:24:16 UTC

Description jaudet 2014-07-09 20:47:57 UTC
Description of problem:
After issuing a successful HTTP POST to api/v2/operatingsystems, an HTTP 200 response is received. An HTTP 201 should be received.

Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.21-1.el6sat.noarch
* foreman-compute-1.6.0.21-1.el6sat.noarch
* foreman-gce-1.6.0.21-1.el6sat.noarch
* foreman-libvirt-1.6.0.21-1.el6sat.noarch
* foreman-ovirt-1.6.0.21-1.el6sat.noarch
* foreman-postgresql-1.6.0.21-1.el6sat.noarch
* foreman-proxy-1.6.0.9-1.el6sat.noarch
* foreman-selinux-1.6.0-5.el6sat.noarch
* foreman-vmware-1.6.0.21-1.el6sat.noarch
* katello-1.5.0-26.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.53-1.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Issue an HTTP POST request to api/v2/operatingsystems path and specify all required fields.
2. Save response.
3. Examine status code of response received.

Actual results:
HTTP 200 status code

Expected results:
HTTP 201 status code

Additional info:
A pull request with the relevant tests is in progress. Before the PR is accepted, you can view the tests here [1], and after the PR is accepted, you can view the tests here [2].

[1] https://github.com/Ichimonji10/robottelo/blob/operatingsystems/tests/foreman/api/test_operatingsystem_v2.py#L46-L68
[2] https://github.com/omaciel/robottelo/blob/master/tests/foreman/api/test_operatingsystem_v2.py#L46-L68

Comment 1 RHEL Product and Program Management 2014-07-09 20:53:57 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 jaudet 2014-07-09 21:13:33 UTC
The PR was accepted, and you can now view the relevant test code here: https://github.com/omaciel/robottelo/blob/master/tests/foreman/api/test_operatingsystem_v2.py#L47-L70

Comment 4 jaudet 2014-07-11 19:59:04 UTC
A PR is in progress that will move the relevant test code. If the PR is accepted, you can view the test code here: https://github.com/omaciel/robottelo/blob/master/tests/foreman/api/test_multiple_paths.py#L54-L83

Comment 5 jaudet 2014-07-17 13:48:04 UTC
*** Bug 1118894 has been marked as a duplicate of this bug. ***

Comment 7 jaudet 2014-07-17 13:53:22 UTC
This bug applies to at least four URLs:

* operatingsystems/
* repositories/
* content_views/
* architectures/

Comment 8 Dominic Cleal 2014-07-21 15:12:12 UTC
Created redmine issue http://projects.theforeman.org/issues/6701 from this bug

Comment 9 jaudet 2014-07-24 15:41:18 UTC
Dominic, can you update that bug report with all four URLs?

Comment 10 jaudet 2014-08-04 16:16:35 UTC
I see you've updated the Redmine issue. Thank you, Dominic.

Comment 11 Roman Plevka 2016-11-24 10:39:18 UTC
This bug applies to at least one more URL:

*organizations/

Comment 12 Bryan Kearney 2017-03-14 17:10:36 UTC
An upstream issue has been opened for this. When this is fixed, the next version of satellite will contain the fix. We will no longer be tracking this downstream. If you feel this was closed in error, please feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.