Bug 1118046 - broken package - missing saslauth group
Summary: broken package - missing saslauth group
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1118047 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 22:00 UTC by Ömer Fadıl Usta
Modified: 2014-07-20 00:41 UTC (History)
13 users (show)

Fixed In Version: systemd-215-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-20 00:41:43 UTC


Attachments (Terms of Use)

Description Ömer Fadıl Usta 2014-07-09 22:00:41 UTC
Description of problem:

groupadd: cannot open /etc/group
useradd: group 'saslauth' does not exist
error: %prein(cyrus-sasl-2.1.26-17.fc21.x86_64) scriptlet failed, exit status 6
Error in PREIN scriptlet in rpm package cyrus-sasl-2.1.26-17.fc21.x86_64
  Installing : cyrus-sasl-devel-2.1.26-17.fc21.x86_64                                                                                                                                         56/102 
error: cyrus-sasl-2.1.26-17.fc21.x86_64: install failed

Rawhide 9/7/2014 and all packages have updated.

Also i'm getting groupadd: cannot open /etc/group while installing almost all packages ( even there is a /etc/group file )

Comment 1 Tomas Mraz 2014-07-10 07:58:40 UTC
Can you please show the output of rpm -q shadow-utils ?

Also if you try to use 'groupadd -r somegroup' as root do you see the same error?
And if you see the error, could you please strace the groupadd command and look for open(/etc/group) and post the surrounding lines of the strace?

Comment 2 Petr Lautrbach 2014-07-10 13:28:15 UTC
Update works for on my Rawhide. How does the privileges on /etc/group look like?

# ls -lZ /etc/group

Comment 3 Petr Lautrbach 2014-07-10 14:03:59 UTC
So this is most probably systemd-sysuser problem:

 # ls -lZ /etc/group
-rw-r--r--. root root system_u:object_r:etc_t:s0       /etc/group

# ls -l /etc/group
-rw-r--r--. 1 root root 1205 Jul  8 19:05 /etc/group

# matchpathcon /etc/group
/etc/group      system_u:object_r:passwd_file_t:s0

Last reboot - Tue Jul  8 19:05

Comment 4 Zbigniew Jędrzejewski-Szmek 2014-07-10 14:19:23 UTC
*** Bug 1118047 has been marked as a duplicate of this bug. ***

Comment 5 Ömer Fadıl Usta 2014-07-11 11:36:53 UTC
Hello again ,


[usta@sakura ~]$ rpm -q shadow-utils
shadow-utils-4.1.5.1-13.fc21.x86_64



[usta@sakura ~]$ sudo groupadd -r deneme

(There isn't any error ) 

[usta@sakura ~]$ cat /etc/group
root:x:0:
bin:x:1:
daemon:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mem:x:8:
kmem:x:9:
wheel:x:10:usta
cdrom:x:11:
mail:x:12:
man:x:15:
dialout:x:18:
floppy:x:19:
games:x:20:
tape:x:30:
video:x:39:
ftp:x:50:
lock:x:54:
audio:x:63:
nobody:x:99:
users:x:100:
utmp:x:22:
utempter:x:35:
avahi-autoipd:x:170:
input:x:999:
systemd-journal:x:190:
systemd-timesync:x:998:
systemd-network:x:997:
systemd-resolve:x:996:
systemd-bus-proxy:x:995:
dbus:x:81:
polkitd:x:994:
dip:x:40:
tss:x:59:
ssh_keys:x:993:
abrt:x:173:
unbound:x:992:
avahi:x:70:
rtkit:x:172:
chrony:x:991:
rpc:x:32:
mysql:x:27:
colord:x:990:
openvpn:x:989:
pulse-access:x:988:
pulse:x:171:
sddm:x:987:
nm-openconnect:x:986:
rpcuser:x:29:
nfsnobody:x:65534:
sshd:x:74:
slocate:x:21:
tcpdump:x:72:
usta:x:1000:usta
systemd-journal-gateway:x:985:
deneme:x:984:


[usta@sakura ~]$ ls -lZ /etc/group
-rw-r--r--. root root system_u:object_r:passwd_file_t:s0 /etc/group


by the way, is this bug related to #1118017 ? and i'm not sure if i 
marked that bug in correct component or not. If it is not ,could you please
assigned it for correct component.

Comment 6 Ömer Fadıl Usta 2014-07-11 11:43:06 UTC
and if needed :

[usta@sakura ~]$ cat /etc/passwd
root:x:0:0:root:/root:/bin/bash
bin:x:1:1:bin:/bin:/sbin/nologin
daemon:x:2:2:daemon:/sbin:/sbin/nologin
adm:x:3:4:adm:/var/adm:/sbin/nologin
lp:x:4:7:lp:/var/spool/lpd:/sbin/nologin
sync:x:5:0:sync:/sbin:/bin/sync
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
halt:x:7:0:halt:/sbin:/sbin/halt
mail:x:8:12:mail:/var/spool/mail:/sbin/nologin
operator:x:11:0:operator:/root:/sbin/nologin
games:x:12:100:games:/usr/games:/sbin/nologin
ftp:x:14:50:FTP User:/var/ftp:/sbin/nologin
nobody:x:99:99:Nobody:/:/sbin/nologin
avahi-autoipd:x:170:170:Avahi IPv4LL Stack:/var/lib/avahi-autoipd:/sbin/nologin
systemd-timesync:x:999:998:systemd Time Synchronization:/:/usr/sbin/nologin
systemd-network:x:998:997:systemd Network Management:/:/usr/sbin/nologin
systemd-resolve:x:997:996:systemd Resolver:/:/usr/sbin/nologin
systemd-bus-proxy:x:996:995:systemd Bus Proxy:/:/usr/sbin/nologin
dbus:x:81:81:System message bus:/:/sbin/nologin
polkitd:x:995:994:User for polkitd:/:/sbin/nologin
tss:x:59:59:Account used by the trousers package to sandbox the tcsd daemon:/dev/null:/sbin/nologin
abrt:x:173:173::/etc/abrt:/sbin/nologin
unbound:x:994:992:Unbound DNS resolver:/etc/unbound:/sbin/nologin
avahi:x:70:70:Avahi mDNS/DNS-SD Stack:/var/run/avahi-daemon:/sbin/nologin
rtkit:x:172:172:RealtimeKit:/proc:/sbin/nologin
chrony:x:993:991::/var/lib/chrony:/sbin/nologin
rpc:x:32:32:Rpcbind Daemon:/var/lib/rpcbind:/sbin/nologin
mysql:x:27:27:MariaDB Server:/var/lib/mysql:/sbin/nologin
colord:x:992:990:User for colord:/var/lib/colord:/sbin/nologin
openvpn:x:991:989:OpenVPN:/etc/openvpn:/sbin/nologin
pulse:x:171:171:PulseAudio System Daemon:/var/run/pulse:/sbin/nologin
sddm:x:990:987:Simple Desktop Display Manager:/var/lib/sddm:/sbin/nologin
nm-openconnect:x:989:986:NetworkManager user for OpenConnect:/:/sbin/nologin
rpcuser:x:29:29:RPC Service User:/var/lib/nfs:/sbin/nologin
nfsnobody:x:65534:65534:Anonymous NFS User:/var/lib/nfs:/sbin/nologin
sshd:x:74:74:Privilege-separated SSH:/var/empty/sshd:/sbin/nologin
tcpdump:x:72:72::/:/sbin/nologin
usta:x:1000:1000:Ömer Fadıl Usta:/home/usta:/bin/bash
systemd-journal-gateway:x:985:985:systemd Journal Gateway:/:/sbin/nologin

Comment 7 Ömer Fadıl Usta 2014-07-11 11:49:43 UTC
Also There is a missing line for systemd-journal-gateway and systemd-journal in /etc/shadow  . I'm not sure if they must be in /etc/shadow :

[usta@sakura ~]$ sudo cat /etc/group | grep systemd
systemd-journal:x:190:
systemd-timesync:x:998:
systemd-network:x:997:
systemd-resolve:x:996:
systemd-bus-proxy:x:995:
systemd-journal-gateway:x:985:

[usta@sakura ~]$ sudo cat /etc/shadow | grep systemd
systemd-timesync:!!:16260::::::
systemd-network:!!:16260::::::
systemd-resolve:!!:16260::::::
systemd-bus-proxy:!!:16260::::::

Comment 8 Tomas Mraz 2014-07-14 08:41:40 UTC
This might have caused bug 1118017 for you.

Comment 9 Zbigniew Jędrzejewski-Szmek 2014-07-14 14:15:11 UTC
Upstream commit http://cgit.freedesktop.org/systemd/systemd/commit/?id=a334cbba7222d3d7d.

Comment 11 Zbigniew Jędrzejewski-Szmek 2014-07-14 15:21:15 UTC
(In reply to Ömer Fadıl Usta from comment #10)
> f7f628b5db770feb8b18990436baefaec55c460b
That's just refactoring, not important.

Comment 12 Ömer Fadıl Usta 2014-07-17 02:18:40 UTC
It looks like this bug have fixed with current updates in rawhide.
I can confirm that now it looks like everything working perfect.

On the other hand i'm not sure if systemd-journal-gateway and systemd-journal lines exist in /etc/shadow . I have added them manually but not sure if newly builds have them.


Note You need to log in before you can comment on or make changes to this bug.