Bug 1118047 - after updating to 215-3 system broken (not tested -2)
Summary: after updating to 215-3 system broken (not tested -2)
Keywords:
Status: CLOSED DUPLICATE of bug 1118046
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 22:02 UTC by Igor Gnatenko
Modified: 2014-07-10 14:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-10 14:19:23 UTC


Attachments (Terms of Use)
journal from bad boot (199.69 KB, text/plain)
2014-07-09 22:02 UTC, Igor Gnatenko
no flags Details

Description Igor Gnatenko 2014-07-09 22:02:19 UTC
Created attachment 916958 [details]
journal from bad boot

after updating - rebooted and can't work.
firewalld cant start, other services can't start (probably requires dbus)



P.S. I'm updating from koji latest.

Comment 1 Igor Gnatenko 2014-07-09 22:04:05 UTC
Jul 10 01:27:49 X1Carbon.localdomain dbus-daemon[790]: Could not get password database information for UID of current process: User "???" unknown or no memory to allocate password entry

I think that's mtab-generating related.

Comment 2 Igor Gnatenko 2014-07-09 22:07:16 UTC
downgraded to 215-1 and it works again.

Comment 3 Zbigniew Jędrzejewski-Szmek 2014-07-10 00:35:08 UTC
I don't see how the changes between -1 and -3 could be relevant. I suspect that there's a race, and systemd-sysuser either does something wrong, or dbus cannot access /etc/passwd because of a lock, or something like that. But chrony.service and dbus.service and avahi-daemon.service should all start after sysinit.target, and systemd-sysusers should be done at this point.

Can you install -3 again, and boot in debug mode and start a debug shell (e.g. by appending 'systemd.debug-shell systemd.log-level=debug' on the kernel command line), switch to it with ctrl-alt-f9 when the boot fails and show the output of

ls -l /etc/passwd /etc/group /etc/shadow /etc/gshadow
getent passwd chrony
getent group chrony

and

journalctl -b -o short-monotonic

(and anything else which might show us what the problem with the user database is)?

Comment 4 Igor Gnatenko 2014-07-10 06:25:49 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #3)
> I don't see how the changes between -1 and -3 could be relevant. I suspect
> that there's a race, and systemd-sysuser either does something wrong, or
> dbus cannot access /etc/passwd because of a lock, or something like that.
> But chrony.service and dbus.service and avahi-daemon.service should all
> start after sysinit.target, and systemd-sysusers should be done at this
> point.
> 
> Can you install -3 again, and boot in debug mode and start a debug shell
> (e.g. by appending 'systemd.debug-shell systemd.log-level=debug' on the
> kernel command line), switch to it with ctrl-alt-f9 when the boot fails and
> show the output of
> 
> ls -l /etc/passwd /etc/group /etc/shadow /etc/gshadow
> getent passwd chrony
> getent group chrony
> 
> and
> 
> journalctl -b -o short-monotonic
> 
> (and anything else which might show us what the problem with the user
> database is)?
I will try tonight.

Comment 5 Zbigniew Jędrzejewski-Szmek 2014-07-10 14:19:23 UTC

*** This bug has been marked as a duplicate of bug 1118046 ***


Note You need to log in before you can comment on or make changes to this bug.