Bug 1118068 - Rubygem-Staypuft: rhel-osp-installer failed with errors during db:seed.
Summary: Rubygem-Staypuft: rhel-osp-installer failed with errors during db:seed.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Mike Burns
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-09 23:19 UTC by Omri Hochman
Modified: 2015-12-07 13:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:35:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Omri Hochman 2014-07-09 23:19:42 UTC
Rubygem-Staypuft: rhel-osp-installer failed with errors during db:seed.  


Steps:
-------
(1) Attempt to run rhel-osp-installer . 


Restuls:
--------
Errors during seed (look below at the installer.log) 


Environment:
------------
rhel-osp-installer-0.1.0-2.el6ost.noarch
puppet-3.6.2-1.el6.noarch
puppet-server-3.6.2-1.el6.noarch
openstack-puppet-modules-2014.1-18.1.el6ost.noarch
foreman-1.6.0.15-1.el6sat.noarch
openstack-foreman-installer-2.0.12-2.el6ost.noarch



How would you like to proceed?:
1. Proceed with the above values
2. Change SSH public key
3. Change Root Password
4. Display root password
1
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
 /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
Installing             Debug: Executing '/sbin/chkconfig foreman-tasks'   [99%] [............................................................................................................................... ]



Not running provisioning configuration since installation encountered errors, exit code was 6
  Something went wrong! Check the log for ERROR-level output
  The full log is at /var/log/foreman-installer/foreman-installer.log


Installation.log 
------------------
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:                                                      ^
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:552: syntax error, unexpected ',', expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:553: syntax error, unexpected tASSOC, expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:           'quickstack::storage_backend::cinder'    => {
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:                                                      ^
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:557: syntax error, unexpected ',', expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:558: syntax error, unexpected tASSOC, expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:           'quickstack::nova_network::compute'      => {
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:                                                      ^
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:581: syntax error, unexpected ',', expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:582: syntax error, unexpected tASSOC, expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:           'quickstack::neutron::compute'           => {
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:                                                      ^
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:605: syntax error, unexpected ',', expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:606: syntax error, unexpected tASSOC, expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:           'quickstack::pacemaker::rsync::keystone' => {
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns:                                                      ^
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:607: syntax error, unexpected '}', expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.1.8.2/app/lib/staypuft/seeder.rb:736: syntax error, unexpected $end, expecting keyword_end
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: 
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Tasks: TOP => db:seed
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: (See full trace by running task with --trace)
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/05-architectures.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/07-config_templates.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/08-partition_tables.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/10-installation_media.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/11-permissions.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/11-roles.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/11-smart_proxy_features.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/12-auth_sources.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/13-compute_profiles.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: Seeding /usr/share/foreman/db/seeds.d/15-bookmarks.rb
[ WARN 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]/returns: All seed files executed
[ERROR 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: Failed to call refresh: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]
[ERROR 2014-07-09 17:40:09 main]  /Stage[main]/Foreman::Database/Foreman::Rake[db:seed]/Exec[foreman-rake-db:seed]: /usr/sbin/foreman-rake db:seed returned 1 instead of one of [0]

Comment 2 Hugh Brock 2014-07-11 14:32:49 UTC
I believe this is fixed in poodle 7.4 as of yesterday...

Comment 7 Alexander Chuzhoy 2014-07-21 16:22:24 UTC
Verified: rhel-osp-installer-0.1.1-1.el6ost.noarch


The rhel-osp-installer completes with no issues and the reported error doesn't reproduce.

Comment 8 errata-xmlrpc 2014-08-04 18:35:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.