Bug 1118093 - kernel-3.15.3 shuts off second ixgbe NIC on boot
Summary: kernel-3.15.3 shuts off second ixgbe NIC on boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: fedora-kernel-ethernet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 01:46 UTC by Sam
Modified: 2014-11-13 22:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-13 22:59:40 UTC


Attachments (Terms of Use)

Description Sam 2014-07-10 01:46:46 UTC
Description of problem: I updated to kernel-3.14.8 today, and upon boot discovered that the second of my two Intel interfaces (Supermicro motherboard) was shut off - not even any blinking lights. ethtool reported a Loopback test failure (12) and Link test failure (1). But more obviously, the NIC was totally dead. When I reverted to kernel-3.14.8, all was good again.

Version-Release number of selected component (if applicable):

kernel-3.14.8 and ixgbe driver

How reproducible: completely on this one machine, rebooted many times with 100% failure under kernel-3.14.8

Steps to Reproduce:
1. Have two Intel NICs on a Supermicro motherboard
2. Update to kernel-3.14.8
3. Reboot

Actual results:

Second NIC is dead.

Expected results:

Second NIC works just like the first.

Additional info:

# ethtool -i eno1
driver: ixgbe
version: 3.19.1-k
firmware-version: 0x80000314
bus-info: 0000:03:00.1
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes

Comment 1 Sam 2014-07-10 01:52:08 UTC
ARGH!!! I meant kernel-3.15.3 is the buggy kernel and kernel-3.14.8 works fine! Got my kernel versions confused.

Also that ethtool run is under kernel-3.14.8 - not the buggy kernel. I have to keep the server up and running.

Comment 2 Justin M. Forbes 2014-11-13 15:55:21 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.

Comment 3 Sam 2014-11-13 22:59:40 UTC
This bug was fixed in 2.16.6-203.fc20.x86_64. I tried to find this bug id to report it, and couldn't so thanks for the ping today, Justin. And thanks for fixing the bug, folks!


Note You need to log in before you can comment on or make changes to this bug.