Bug 1118124 - Rule Flow mini-icon not appearing when Full Object Library selection is chosen
Summary: Rule Flow mini-icon not appearing when Full Object Library selection is chosen
Keywords:
Status: CLOSED DUPLICATE of bug 1067037
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Tihomir Surdilovic
QA Contact: Sona Mala
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 03:44 UTC by Douglas Hoffman
Modified: 2014-10-26 20:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-10 11:44:36 UTC
Type: Bug


Attachments (Terms of Use)
Full Object Library selection (27.89 KB, image/png)
2014-07-10 03:44 UTC, Douglas Hoffman
no flags Details
Missing mini-icons on node while "Full" object library is selected (44.45 KB, image/png)
2014-07-10 03:46 UTC, Douglas Hoffman
no flags Details
Mini-icons present when "Simple" or "RuleFlow" object library choices are selected. (53.10 KB, image/png)
2014-07-10 03:47 UTC, Douglas Hoffman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 973049 None None None Never
Red Hat Bugzilla 1067037 None None None Never

Internal Links: 973049 1067037

Description Douglas Hoffman 2014-07-10 03:44:02 UTC
Created attachment 916987 [details]
Full Object Library selection

Description of problem:


Version-Release number of selected component (if applicable): BRMS 6.0.2 GA standalone for EAP 6.1.1 GA


How reproducible:
Using Fedora 20 with Firefox 26 and Chrome browsers

Steps to Reproduce:
1. Go to Authoring -> Project Authoring -> New Item -> Business Process
2. Open the left pane "Object Library" and make sure "Full" is selected from the drop-down list.
3. Click on the newly created node. Notice no mini icons appear.

Actual results:
Mini icons should be available for rule flow process creation regardless of selected object library.

Expected results:
Mini-icons appears for task creation.

Additional info:
Icons appear with the "Simple" and "RuleFlow" object library choices. For some reason, "Full" doesn't seem to function as expected. With Firefox, it appears "Full" is the default setting for the object library since I had to select one of the other two choices in order to get the mini-icons to appear.

Comment 1 Douglas Hoffman 2014-07-10 03:46:07 UTC
Created attachment 916988 [details]
Missing mini-icons on node while "Full" object library is selected

Comment 2 Douglas Hoffman 2014-07-10 03:47:20 UTC
Created attachment 916989 [details]
Mini-icons present when "Simple" or "RuleFlow" object library choices are selected.

Comment 4 Sona Mala 2014-07-10 09:10:14 UTC
Hi,
please see this issue 1067037. It has been already reported but for BPMS platform. 

Originally, BRMS should contain only a lighter version of jBPM Designer (see 973049). I am not sure if Full Object Library should work in BRMS.

Comment 5 Kris Verlaenen 2014-07-10 11:44:36 UTC

*** This bug has been marked as a duplicate of bug 1067037 ***


Note You need to log in before you can comment on or make changes to this bug.