Bug 1118180 - SDHC card not mounted on insert.
Summary: SDHC card not mounted on insert.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 07:08 UTC by Randy Berry
Modified: 2014-10-07 13:31 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-07 13:31:26 UTC


Attachments (Terms of Use)
journalctl -b (1.07 MB, text/plain)
2014-07-10 22:41 UTC, Randy Berry
no flags Details
journalctl -b -o short-monotoni (1.07 MB, text/plain)
2014-07-10 22:45 UTC, Randy Berry
no flags Details
journalctl -b -o short-monotonic (1.09 MB, text/plain)
2014-07-10 23:02 UTC, Randy Berry
no flags Details
dmesg (162.26 KB, text/plain)
2014-07-10 23:06 UTC, Randy Berry
no flags Details

Description Randy Berry 2014-07-10 07:08:27 UTC
Description of problem:
When I insert my 8gb SDHC card it is not mounted at all. lsusb recognizes the reader, dmesg shows the card being inserted and removed but I cannot mount it either manually or automatically. (Redirect where relevant.)

Version-Release number of selected component (if applicable):
All current and -testing

Steps to Reproduce:
1. Insert card



Actual results:
Card does not mount, automatically or manually

Expected results:
accessible device.

Additional info:
dmesg http://paste.fedoraproject.org/116872/40497591
lsusb http://paste.fedoraproject.org/116873/14049759

Comment 1 Randy Berry 2014-07-10 07:39:48 UTC
Reassigning to udev possible systemd issue as well?

journalctl -f: http://fpaste.org/116877/

Comment 2 Randy Berry 2014-07-10 08:45:20 UTC
OK, it mounted out of the blue, and is accessible, but it's slow as molasses.  This is the card out of my camera. It's currently copying to a local drive at a speed of 51 kB/sec. Quite pathetic actually.

Comment 3 Zbigniew Jędrzejewski-Szmek 2014-07-10 12:22:40 UTC
Please paste the output of 'journalctl -b -o short-monotonic' and 'lsblk' after interserting the card.

Also indicate the kernel and systemd rpm versions.

Comment 4 Randy Berry 2014-07-10 19:38:34 UTC
kernel-PAE-3.15.3-200.fc20.i686 (from testing) 
kernel-PAE-3.14.9-200.fc20.i686
kernel-PAE-3.15.4-200.fc20.i686

(Same result with all current and -testing kernels)

systemd-208-19.fc20.i686

lsblk 

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0 465.8G  0 disk  
├─sda1                                          8:1    0   500M  0 part  /boot
└─sda2                                          8:2    0 465.3G  0 part  
  └─luks-715b291b-3642-4bec-ba43-6a6b9a313112 253:0    0 465.3G  0 crypt 
    ├─fedora_krickits--win-root               253:1    0    50G  0 lvm   /
    ├─fedora_krickits--win-swap               253:2    0   3.2G  0 lvm   [SWAP]
    └─fedora_krickits--win-home               253:3    0 412.1G  0 lvm   /home
sdb                                             8:16   0 301.7G  0 disk  
└─sdb1                                          8:17   0 301.7G  0 part  /mnt/4234EB7C34EB7179
sdc                                             8:32   1   7.4G  0 disk  
└─sdc1                                          8:33   1   7.4G  0 part  
sr0                                            11:0    1  1024M  0 rom   
sr1                                            11:1    1  1024M  0 rom  

journalctl -b -o short-monotonic (first page)

-- Logs begin at Wed 2013-07-03 10:04:43 EDT, end at Thu 2014-07-10 15:30:54 EDT. --
[    1.389045] krickitz.merlinfund.lan systemd-journal[88]: Runtime journal is using 8.0M (max al
[    1.389689] krickitz.merlinfund.lan systemd-journal[88]: Runtime journal is using 8.0M (max al
[    0.000000] krickitz.merlinfund.lan kernel: Initializing cgroup subsys cpuset
[    0.000000] krickitz.merlinfund.lan kernel: Initializing cgroup subsys cpu
[    0.000000] krickitz.merlinfund.lan kernel: Initializing cgroup subsys cpuacct
[    0.000000] krickitz.merlinfund.lan kernel: Linux version 3.15.4-200.fc20.i686+PAE (mockbuild@
[    0.000000] krickitz.merlinfund.lan kernel: e820: BIOS-provided physical RAM map:
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009f
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000000f0000-0x00000000000ff
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000cfe86
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000cfe86c00-0x00000000cfe88
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000cfe88c00-0x00000000cfe8a
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000cfe8ac00-0x00000000d3fff
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fed00
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000fed20000-0x00000000fed9f
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000feeff
[    0.000000] krickitz.merlinfund.lan kernel: BIOS-e820: [mem 0x00000000ffb00000-0x00000000fffff
[    0.000000] krickitz.merlinfund.lan kernel: NX (Execute Disable) protection: active
[    0.000000] krickitz.merlinfund.lan kernel: SMBIOS 2.3 present.
[    0.000000] krickitz.merlinfund.lan kernel: DMI: Dell Inc.                 OptiPlex GX620     
[    0.000000] krickitz.merlinfund.lan kernel: e820: update [mem 0x00000000-0x00000fff] usable ==
[    0.000000] krickitz.merlinfund.lan kernel: e820: remove [mem 0x000a0000-0x000fffff] usable

Comment 5 Zbigniew Jędrzejewski-Szmek 2014-07-10 20:55:54 UTC
The first page of logs is not going to be very informative. Can't you attach the whole thing?

Also, what does it mean that you cannot mount it manually?

Comment 6 Randy Berry 2014-07-10 22:41:40 UTC
Created attachment 917198 [details]
journalctl -b

Comment 7 Randy Berry 2014-07-10 22:45:41 UTC
Created attachment 917199 [details]
journalctl -b -o short-monotoni

Comment 8 Randy Berry 2014-07-10 22:50:34 UTC
Wrong choice of words. It appears to be mounted. as in gnome-disks knows it's there but it is inaccessible.

Comment 9 Randy Berry 2014-07-10 23:02:09 UTC
Created attachment 917200 [details]
journalctl -b -o short-monotonic

This was created AFTER the device was unplugged and plugged back in with the card inserted. CARD 1 as it's known then shows up in thunar but is slow as all get out.

Comment 10 Randy Berry 2014-07-10 23:06:29 UTC
Created attachment 917201 [details]
dmesg

This is created shortly AFTER device is unplugged, and plugged back in with the card inserted.

Comment 11 Zbigniew Jędrzejewski-Szmek 2014-07-11 03:20:13 UTC
I'm sorry, but this looks like a hardware problem.

[45658.112061] krickitz.merlinfund.lan kernel: usb 1-4: reset high-speed USB device number 9 using ehci-pci
[45659.150985] krickitz.merlinfund.lan systemd-udevd[780]: worker [12815] terminated by signal 9 (Killed)
[45689.183454] krickitz.merlinfund.lan systemd-udevd[780]: worker [12817] /devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/host7/target7:0:0/7:0:0:0/block/sdc timeout; kill it
[45689.184608] krickitz.merlinfund.lan systemd-udevd[780]: seq 2273 '/devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/host7/target7:0:0/7:0:0:0/block/sdc' killed
[45690.112061] krickitz.merlinfund.lan kernel: usb 1-4: reset high-speed USB device number 9 using ehci-pci
[45691.151237] krickitz.merlinfund.lan systemd-udevd[780]: worker [12817] terminated by signal 9 (Killed)
[45702.427048] krickitz.merlinfund.lan kernel: usb 1-4: reset high-speed USB device number 9 using ehci-pci
[45703.353987] krickitz.merlinfund.lan kernel: sd 7:0:0:0: [sdc] Device not ready
[45703.353995] krickitz.merlinfund.lan kernel: sd 7:0:0:0: [sdc]  
[45703.353998] krickitz.merlinfund.lan kernel: Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[45703.354023] krickitz.merlinfund.lan kernel: sd 7:0:0:0: [sdc]  
[45703.354028] krickitz.merlinfund.lan kernel: Sense Key : Not Ready [current] 
[45703.354040] krickitz.merlinfund.lan kernel: sd 7:0:0:0: [sdc]  
[45703.354047] krickitz.merlinfund.lan kernel: Add. Sense: Medium not present
[45703.354054] krickitz.merlinfund.lan kernel: sd 7:0:0:0: [sdc] CDB: 
[45703.354058] krickitz.merlinfund.lan kernel: Read(10): 28 00 00 00 20 18 00 00 08 00
[45703.354081] krickitz.merlinfund.lan kernel: end_request: I/O error, dev sdc, sector 8216
[45703.354090] krickitz.merlinfund.lan kernel: Buffer I/O error on device sdc1, logical block 3
[45721.181642] krickitz.merlinfund.lan systemd-udevd[780]: worker [12818] /devices/pci0000:00/0000:00:1d.7/usb1/1-4/1-4:1.0/host7/target7:0:0/7:0:0:0/block/sdc/sdc1 timeout; kill it

It possibly could also be some kernel issue, if everything was working with older kernel version, and stopped after an upgrade. You list a few different kernel versions, which suggests that this is not a kernel regression. Please reopen if you think the medium is fine and there's a kernel problem.

Comment 12 Randy Berry 2014-07-11 04:23:37 UTC
I've reopened the bug and reassigned it to kernel. The last recorded time that I am certain it was working was 04/18/14. So anytime after that is when it quit.

It *was* working fine on Fedora. I can't say exactly when it quit, I don't use my camera much so it was only noticed recently. The hardware works on Windows, but I hate Windows.

Comment 13 Randy Berry 2014-10-07 13:31:26 UTC
OK, this is strange. One card reader used to work just fine on the rear USB ports of my machine. I ordered another one and now neither will work on the rear ports. But the old one and the new one work just fine on the front USB ports. The rear ports work with every other USB device I have.

I'll close this bug as it appears to work, it's just an inconvenience that they won't work on the rear ports anymore.


Note You need to log in before you can comment on or make changes to this bug.