Bug 1118197 - Product refresh does not work when network is not available
Summary: Product refresh does not work when network is not available
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 08:05 UTC by Sergio Ocon
Modified: 2017-03-22 20:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-22 20:55:50 UTC


Attachments (Terms of Use)

Description Sergio Ocon 2014-07-10 08:05:29 UTC
Description of problem:
When you try to show Products or Product related information while Sat 6 is not connected to the Internet the list of Products does not appaear and the spinning wheel keeps there forevere

Version-Release number of selected component (if applicable):
6.0.3

How reproducible:
Always

Steps to Reproduce:
Create a VM with Satellite, synchronize products, repos.
Disconnect the machine from the Internet (while keeping in the internal network)


Actual results:
No product information is shown

Expected results:
Syncrhonization does not work
Product management (with old version of files) is 100% functional


Additional info:
Jul  9 12:33:42 satellite6 pulp: pulp.server.agent.direct.services:INFO: Task reply handler, started.
Jul  9 12:33:42 satellite6 pulp: pulp.server.agent.direct.services:INFO: AMQP reply handler started
Jul  9 12:33:42 satellite6 pulp: pulp.server.webservices.application:INFO: *****************************************
********************
Jul  9 12:33:42 satellite6 pulp: pulp.server.webservices.application:INFO: The Pulp server has been successfully ini
tialized
Jul  9 12:33:42 satellite6 pulp: pulp.server.webservices.application:INFO: *****************************************
********************
Jul  9 12:33:57 satellite6 pulp: gofer.transport.qpid.broker:INFO: {satellite6.sergio.cloud:5671} connected to AMQP
Jul  9 12:53:06 satellite6 pulp: pulp.server.async.scheduler:ERROR: could not connect to localhost:27017: [Errno 111
] Connection refused
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:09 satellite6 pulp: pulp.server.async.scheduler:ERROR: could not connect to localhost:27017: [Errno 111
] Connection refused
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:19 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted
Jul  9 12:53:29 satellite6 pulp: kombu.transport.qpid:ERROR: connection aborted

Comment 1 RHEL Product and Program Management 2014-07-10 08:14:20 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Sergio Ocon 2014-11-14 19:00:31 UTC
I've realized that whenever I do something it tries to connect to secure.gravatar.com.

It stops until it times out... that means any change stops for 60 seconds with no reason at all.

Comment 5 Brad Buckingham 2016-12-15 19:09:46 UTC
Hi Sergio, in the current versions of Satellite 6.1.z and 6.2.z, the usage of gravatar has been disabled within the settings.  Based on this, any objection to closing this bugzilla?  Thanks!

Comment 6 Sergio Ocon 2016-12-20 10:07:13 UTC
It is ok then. No objections to close it

Comment 7 Bryan Kearney 2017-03-22 20:55:50 UTC
I do not believe this will be addressed in the next few releases, so I am closing this out. If you feel this was incorrect, please feel free to re-open with additional information.


Note You need to log in before you can comment on or make changes to this bug.