Bug 1118241 - Please update to v0.45
Summary: Please update to v0.45
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: po4a
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 09:33 UTC by Mario Blättermann
Modified: 2014-07-19 02:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-19 02:44:49 UTC


Attachments (Terms of Use)

Description Mario Blättermann 2014-07-10 09:33:57 UTC
Hello,

the po4a package is currently available in v0.44. The latest version is 0.45, released August 21, 2013 [1]. This version features a new module for handling asciidoc which I need to translate a certain project's documentation. Thanks in advance!

[1] https://alioth.debian.org/frs/?group_id=30267

Comment 1 Ralf Corsepius 2014-07-10 10:57:33 UTC
Taking. 

I had a local update pending for a while, but so far had not found sufficient reasons warranting an upgrade to 0.45. Provided what you say and provided Debian has switched to 0.45 in sid and jessie, I am going to upgrade at least on rawhide. Not sure about f21 and below, yet.

Comment 2 Mario Blättermann 2014-07-18 20:08:22 UTC
If it goes in Rawhide only, the mentioned version published almost one year ago would be available to the normal users not before next year. As far as I can assess, this wouldn't match the term "first" in the fundamental standards of our project. Are there good reasons to don't release this version at least in the upcoming f21? Currently po4a is almost a leaf package, only required at runtime by the ikiwiki compiler.

Comment 3 Ralf Corsepius 2014-07-19 02:44:49 UTC
(In reply to Mario Blättermann from comment #2)
> If it goes in Rawhide only, the mentioned version published almost one year
> ago would be available to the normal users not before next year.
Sorry, I should have mentioned to have pushed 0.45 to rawhide and f21, earlier this week (2014-07-14) and closed this BZ ;)

> As far as I
> can assess, this wouldn't match the term "first" in the fundamental
> standards of our project. Are there good reasons to don't release this
> version at least in the upcoming f21?
I'd agree to this, if f21 wasn't branched. ATM, the primary reason for me to be hesitant on upgrading is me wanting to avoid introducing incompatibilities and FTBFS.

> Currently po4a is almost a leaf
> package, only required at runtime by the ikiwiki compiler.
Well, po4a is Build-Required by about a dozen of packages (i.e. used at build-time), to whom I didn't want to introduce new FTBFSes at this point in time.

I did a local rebuilt of these packages and haven't found any new FTBFSes, which was had caused me to proceed and push po4a-0.45 to f21.


Note You need to log in before you can comment on or make changes to this bug.