Bug 1118243 - Adding a launcher to panel does not respect [X] Lock To Panel
Summary: Adding a launcher to panel does not respect [X] Lock To Panel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-panel
Version: 6.5
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 09:40 UTC by Phil Wyett
Modified: 2017-12-06 10:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 10:42:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 0005012 None None None Never

Description Phil Wyett 2014-07-10 09:40:57 UTC
Description of problem:
Adding a launcher to panel does not respect [X] Lock To Panel


How reproducible:

Always


Steps to Reproduce:

From the Applications menu I navigated to an application of interest, for example Passwords and Encryption keys. I right clicked on the menu entry and select "Add this launcher to panel". The launcher appears to the right of the gnotes launcher as expected. I now right click on the Passwords and Encryption key launcher and check [X] Lock To Panel.

I repeat the process and add for example the calculator launcher to the panel. The calculator launcher appears between the gnotes launcher and the Passwords and Encryption keys launcher. The fact that the Passwords... launcher is Locked To Panel seems to be ignored. The Passwords... launcher is moved to the right event though it is supposed to be locked in position.


Actual results:

Newly added items mix in with locked items.


Expected results:

New items appear at the side of locked items.

Comment 2 Jan Kurik 2017-12-06 10:42:12 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.