Bug 1118357 - Horizon doesn't notify when fail to attach a volume
Summary: Horizon doesn't notify when fail to attach a volume
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Ido Ovadia
URL:
Whiteboard: storage
Depends On: 1029919
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 13:53 UTC by Yogev Rabl
Modified: 2016-05-27 07:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-27 07:40:23 UTC


Attachments (Terms of Use)
The horizon log (29.43 KB, text/x-log)
2014-07-10 13:53 UTC, Yogev Rabl
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1340197 None None None Never

Description Yogev Rabl 2014-07-10 13:53:55 UTC
Created attachment 917097 [details]
The horizon log

Description of problem:
Horizon doesn't notify when the attachment of volume process fail with Errors.
The nova-compute log show errors during the process of the volume attachment but the Horizon doesn't present the failure and the error. 

Version-Release number of selected component (if applicable):
python-django-horizon-2014.1-7.el7ost.noarch
openstack-nova-network-2014.1-7.el7ost.noarch
python-novaclient-2.17.0-2.el7ost.noarch
openstack-nova-common-2014.1-7.el7ost.noarch
openstack-nova-compute-2014.1-7.el7ost.noarch
openstack-nova-conductor-2014.1-7.el7ost.noarch
openstack-nova-scheduler-2014.1-7.el7ost.noarch
openstack-nova-api-2014.1-7.el7ost.noarch
openstack-nova-cert-2014.1-7.el7ost.noarch
openstack-nova-novncproxy-2014.1-7.el7ost.noarch
python-nova-2014.1-7.el7ost.noarch
openstack-nova-console-2014.1-7.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Follow the step of the bug: https://bugs.launchpad.net/nova/+bug/1340169
2. In the Horizon try to attach a volume

Actual results:
The Horizon shows an info message: 
Info: Attaching volume bowl-the-dust to instance cougar-01-fe5510a5-c50c-46ee-9d71-6f8e41a58ecc on /dev/vdc.

The volume status changes to 'attaching' then change back to available.

Expected results:
An error should appear saying "Error: the volume attachment failed"

Additional info:
The Horizon log is attached.
The nova-compute log with the volume attachment error is available in the bug https://bugs.launchpad.net/nova/+bug/1340169

Comment 2 Julie Pichon 2014-07-16 09:47:40 UTC
I'm lowering the priority as this is not urgent but a nice enhancement. Cinder actions are asynchronous which means that Horizon does not know the outcome when the API call is sent out (you can find more details about this at https://bugzilla.redhat.com/show_bug.cgi?id=976279#c3). A planned improvement upstream (while waiting for a proper, larger fix to be implemented either using real time communication or a new Cinder API) is to mark such messages as "informational" rather than "success" to help alleviate the confusion.

Comment 4 Matthias Runge 2016-05-27 07:40:23 UTC
let's handle this upstream. This didn't came back at all since it was opened.


Note You need to log in before you can comment on or make changes to this bug.