Bug 1118367 - When a node has met its capacity, error message reported is misleading
Summary: When a node has met its capacity, error message reported is misleading
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 2.1.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 14:21 UTC by Timothy Williams
Modified: 2018-12-06 17:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-18 19:09:30 UTC


Attachments (Terms of Use)

Description Timothy Williams 2014-07-10 14:21:34 UTC
Description of problem:

When all nodes within a district have reached the maximum capacity of gears on the system (as defined in /etc/openshift/resource_limits.conf) the following error message is reported on gear creation:

Unable to complete the requested operation due to: No district nodes available. Please try again and contact support if the issue persists.

This is a bit misleading and could report a more relevant error, such as "All nodes of size 'small' have reached their maximum capacity".

Version-Release number of selected component (if applicable):
2.1

How reproducible:
Always

Steps to Reproduce:
1. Fill up all nodes within a district
2. Attempt to create an application using the gear size of the full district
3.

Actual results:
Unable to complete the requested operation due to: No district nodes available. Please try again and contact support if the issue persists.

Expected results:
Unable to complete the requested operation due to: "All nodes of size 'small' have reached their maximum capacity". Please try again and contact support if the issue persists.

Additional info:

Comment 2 Timothy Williams 2016-04-18 19:09:30 UTC
In this part of v2's life, this is not severe enough to be considered worth of being resolved. Closing.


Note You need to log in before you can comment on or make changes to this bug.