Bug 1118384 - Scheduling policy update fails in REST
Summary: Scheduling policy update fails in REST
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-api
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Gilad Chaplik
QA Contact: Pavel Stehlik
URL:
Whiteboard: sla
: 1111104 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 14:56 UTC by Nelly Credi
Modified: 2016-02-10 19:42 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.5.0-beta1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:40:59 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30042 master MERGED restapi: fix cluster's schedulingpolicy back-compat Never
oVirt gerrit 30085 ovirt-engine-3.5 MERGED restapi: fix cluster's schedulingpolicy back-compat Never

Description Nelly Credi 2014-07-10 14:56:16 UTC
Description of problem:

Unable to update scheduling policy from evenly_distributed to power_saving via REST API


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create DC
2.create cluster with scheduling policy 'evenly_distributed'
3.send the following command:
curl -v -u "user@domain:password" -H "Content-type: application/xml" -X PUT -d '<cluster><scheduling_policy><policy>power_saving</policy><thresholds low="20"/></scheduling_policy></cluster>' -k 'https://hostName/api/clusters/cluster_id'

Actual results:

Returns cluster info with the same scheduling policy 
<scheduling_policy href="/api/schedulingpolicies/20d25257-b4bd-4589-92a6-c4c5c5d3fd1a" id="20d25257-b4bd-4589-92a6-c4c5c5d3fd1a">
        <name>evenly_distributed</name>
        <policy>evenly_distributed</policy>
        <thresholds high="80" duration="120"/>
        <properties>
            <property>
                <name>CpuOverCommitDurationMinutes</name>
                <value>2</value>
            </property>
            <property>
                <name>HighUtilization</name>
                <value>80</value>
            </property>
        </properties>
    </scheduling_policy>


Expected results:

scheduling policy should have been updated to power_saving

Additional info:

Comment 1 Ohad Basan 2014-09-01 11:51:56 UTC
*** Bug 1111104 has been marked as a duplicate of this bug. ***

Comment 2 Sandro Bonazzola 2014-10-17 12:40:59 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.