Bug 1118423 - SELinux is preventing /usr/bin/mandb from using the 'fsetid' capabilities.
Summary: SELinux is preventing /usr/bin/mandb from using the 'fsetid' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1116165
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a63e62dcfad0c24ab84ca4f8978...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 16:41 UTC by Jared Smith
Modified: 2014-07-16 11:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-16 11:00:27 UTC


Attachments (Terms of Use)

Description Jared Smith 2014-07-10 16:41:33 UTC
Description of problem:
SELinux is preventing /usr/bin/mandb from using the 'fsetid' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that mandb should have the fsetid capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mandb /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:mandb_t:s0-s0:c0.c1023
Target Context                system_u:system_r:mandb_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        mandb
Source Path                   /usr/bin/mandb
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           man-db-2.6.7.1-4.fc21.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-63.fc21.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.16.0-0.rc4.git2.1.fc21.x86_64 #1
                              SMP Wed Jul 9 17:14:09 UTC 2014 x86_64 x86_64
Alert Count                   2
First Seen                    2014-07-10 12:41:02 EDT
Last Seen                     2014-07-10 12:41:10 EDT
Local ID                      b57479f2-5c61-4868-bf39-e909d12279cc

Raw Audit Messages
type=AVC msg=audit(1405010470.559:581): avc:  denied  { fsetid } for  pid=7809 comm="mandb" capability=4  scontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tcontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tclass=capability permissive=0


type=AVC msg=audit(1405010470.559:581): avc:  denied  { fsetid } for  pid=7809 comm="mandb" capability=4  scontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tcontext=system_u:system_r:mandb_t:s0-s0:c0.c1023 tclass=capability permissive=0


type=SYSCALL msg=audit(1405010470.559:581): arch=x86_64 syscall=chmod success=yes exit=0 a0=f1e2d0 a1=1a4 a2=0 a3=634 items=0 ppid=7804 pid=7809 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm=mandb exe=/usr/bin/mandb subj=system_u:system_r:mandb_t:s0-s0:c0.c1023 key=(null)

Hash: mandb,mandb_t,mandb_t,capability,fsetid

Version-Release number of selected component:
selinux-policy-3.13.1-63.fc21.noarch

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.16.0-0.rc4.git2.1.fc21.x86_64
type:           libreport

Potential duplicate: bug 1116165

Comment 1 Miroslav Grepl 2014-07-16 11:00:27 UTC

*** This bug has been marked as a duplicate of bug 1116165 ***


Note You need to log in before you can comment on or make changes to this bug.