Bug 1118454 - [RFE] adding multiple puppet modules to a content view should be simpler
Summary: [RFE] adding multiple puppet modules to a content view should be simpler
Keywords:
Status: CLOSED DUPLICATE of bug 1154400
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 18:14 UTC by Erik M Jacobs
Modified: 2016-08-05 19:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-05 19:38:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Erik M Jacobs 2014-07-10 18:14:31 UTC
Description of problem:
Currently there is no way to add multiple Puppet modules to a content view. Adding 5 modules takes quite a while. Creating a view with 20-30 modules (which might be common) probably takes an excruciatingly long time.

It would be great if we could figure out a way to implement some kind of mass-add modules.

Comment 1 RHEL Product and Program Management 2014-07-10 18:23:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Chris Pitman 2015-03-23 20:38:03 UTC
We have also run into this issue. Here are two possible ways of addressing it, although I'm sure there are more:

1) Take advantage of puppet module metadata (in either Modulefile or metadata.json) to automatically detect missing dependencies in the content view and easily run through all of them to select which version you want. Keep doing this until all dependencies are resolved.

2) Let a user provide a Puppetfile with a listing of puppet modules that should be in the content view. This could either resolve dependencies (puppet-librarian style) or require all dependencies be included (r10k style). Either way, ti would make this a faster process.

Comment 4 Stephen Benjamin 2015-05-07 12:28:15 UTC
Here's a post about using Librarian: https://bitbin.de/blog/2015/05/using-librarian-with-katello/

BZ1127382 breaks hammer puppet-module though, but even if it was working, it's absurd the hoops to jump through.  I should be able to add a puppet module to a content view

Comment 5 Stephen Benjamin 2015-05-07 12:29:37 UTC
Hit submit too early --

I should be able to add a puppet module to a content view based solely on version and name (in the CLI)

For the UI case though that Erik is asking about, not sure how to make that part easier, you always have to select a version (explicit or latest) for each module.

Comment 6 Brad Buckingham 2016-08-05 19:38:06 UTC

*** This bug has been marked as a duplicate of bug 1154400 ***


Note You need to log in before you can comment on or make changes to this bug.