Bug 1118503 - Generic warning on attempting to delete a cluster policy
Summary: Generic warning on attempting to delete a cluster policy
Keywords:
Status: CLOSED DUPLICATE of bug 1189096
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.6.0
Assignee: Tomer Saban
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-10 21:41 UTC by Andrew Dahms
Modified: 2016-02-10 20:19 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-23 10:04:26 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 39413 master ABANDONED webadmin: Added cluster policy attached error Never
oVirt gerrit 39415 ovirt-engine-3.5 ABANDONED webadmin: Added cluster policy attached error Never
oVirt gerrit 39451 ovirt-engine-3.4 ABANDONED webadmin: Added cluster policy attached error Never

Description Andrew Dahms 2014-07-10 21:41:10 UTC
Description of problem:
Attempting to delete a cluster policy when that cluster policy is still attached to a cluster results in the following error message:

"Error while executing action: Cannot remove Cluster Policy. Parameters are invalid."

This warning is difficult to understand and does not provide information to the users as to why they cannot delete the cluster policy.

Version-Release number of selected component (if applicable):
3.4.0-0.21.el6ev

How reproducible:
100%

Steps to Reproduce:
1. Click Configure from the web-admin portal
2. Click Cluster Policies
3. Select a cluster policy attached to a cluster and click Remove

Actual results:
An 'Operation Cancelled' window appears with the above error message.

Expected results:
An error message appears with text along the lines of the following:

"Error while executing action: Cluster policy still attached to cluster. Ensure the cluster policy has been removed from all clusters and retry."

Additional info:

Comment 3 Tomer Saban 2015-08-23 10:04:26 UTC

*** This bug has been marked as a duplicate of bug 1189096 ***


Note You need to log in before you can comment on or make changes to this bug.