Bug 111860 - Check for correct syntax before restart
Summary: Check for correct syntax before restart
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 111861 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-10 23:41 UTC by Diego Torres Milano
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 22:32:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch solving the problem (615 bytes, patch)
2003-12-11 22:18 UTC, Diego Torres Milano
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:566 normal SHIPPED_LIVE Updated dhcp and dhclient packages 2005-05-26 04:00:00 UTC

Description Diego Torres Milano 2003-12-10 23:41:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1)
Gecko/20021003

Description of problem:
dhcp should not be stopped when 'service dhcpd restart' was issued and
there's a syntax error in configuration file.
A systax check should be issued before stopping the server.
This prevents problems when the service is critical.



Version-Release number of selected component (if applicable):
dhcp-3.0pl2

How reproducible:
Always

Steps to Reproduce:
1.Edit dhcpd configuration file and introduce some syntax error
2.servive dhcpd restart
3.
    

Additional info:

Comment 1 Diego Torres Milano 2003-12-11 22:18:43 UTC
Created attachment 96484 [details]
Patch solving the problem

Comment 2 Daniel Walsh 2003-12-29 11:45:24 UTC
*** Bug 111861 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2004-03-25 18:55:26 UTC
patch applied in dhcp-3.0.1rc12-4.src.rpm

Comment 4 John Flanagan 2004-12-21 19:42:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html



Note You need to log in before you can comment on or make changes to this bug.