Bug 1118614 - freecad-0.14.3702 is available
Summary: freecad-0.14.3702 is available
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 07:34 UTC by Upstream Release Monitoring
Modified: 2014-08-11 13:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 13:07:51 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2014-07-11 07:34:03 UTC
Latest upstream release: 0.14.3692
Current version/release in Fedora Rawhide: 0.13-10.fc21
URL: http://sourceforge.net/api/file/index/project-name/free-cad/mtime/desc/limit/200/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Upstream Release Monitoring 2014-07-16 09:30:47 UTC
Latest upstream release: 0.14.3702
Current version/release in Fedora Rawhide: 0.13-10.fc21
URL: http://sourceforge.net/api/file/index/project-name/free-cad/mtime/desc/limit/200/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 2 Richard Shaw 2014-07-16 17:00:46 UTC
I have begun work on the update. Some BR's have changed but so far they have been available in Fedora.

Two known problems remain:
1. FreeCAD no longer builds against official SMESH which hasn't been updated on SF sicne 2011. I have started a discussion in their forums with the developers but have no solution yet.

2. It has not stopped the build (but I could just be not hitting it yet) but FreeCAD wants/requires Coin3 when we only have Coin2.

Comment 3 John Morris 2014-07-16 17:07:30 UTC
I'm pretty slammed and haven't been able to fix the Coin3 packaging.  It'll take me a bit longer, since IIRC there were some build problems that will take some digging into.

Comment 4 Richard Shaw 2014-08-11 13:07:51 UTC
Builds against Coin2 seem to be working fine so far. I'd still like to move to Coin3 at some point but I got 0.14 in stable now so closing this one.


Note You need to log in before you can comment on or make changes to this bug.