Bug 111865 - Graphical boot fails to load with 2129 kernel
Summary: Graphical boot fails to load with 2129 kernel
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-11 00:38 UTC by Eric Herman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 16:51:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Herman 2003-12-11 00:38:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
After I updated the kernel to the latest one, 2.4.22-1.2129.nptl, I
cannot bootgraphically on an initial power-up.

When I turn on the computer, I get the GRUB selection screen, it
begins to boot 2129 in text mode. Then, when it tries to shift to
graphical mode, I get a brief "X" and then the screen goes blank
(monitor light stays green - not amber).

Meanwhile I have plenty of hard disk activity, like the computer is
trying to boot normally. As it reaches the login screen (I think -
because I can't see it), I get a bunch of "clicks" from the monitor,
about a second apart, like it is trying to start graphically, but the
computer can never get there. Eventually, it stops with a 1 cm
horizontal line of random colors across the top of the screen.

If I hit the reset button, the computer boots fine, though it does not
load the graphical start that is in Fedora. 

I have the original ISO 2115 kernel which works perfectly. Also, if I
boot the 2115 kernel, then reboot (at the login screen) and select the
2129 kernel, it will also boot perfectly with the Fedora graphical
startup.

Thoughts? Questions? Help?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.turn on computer
2.select 2129 kernel
3.watch computer fail to start graphically
    

Actual Results:  screen goes blank on boot up

Expected Results:  screen should show graphical loading of OS

Additional info:

Comment 1 Eric Herman 2003-12-11 00:40:03 UTC
I can also give exact hardware if needed since I built the computer
myself. Just let me know what is needed.

Comment 2 Mike A. Harris 2003-12-11 13:03:34 UTC
Attach your X server log and config file, and /var/log/messages,
from a working setup with the older kernel, and then those 3 files
again with the failing configuration.  Also provide the output of
"lsmod" from after XFree86 is started in both kernel bootups.

TIA

Comment 3 Eric Herman 2003-12-17 20:17:54 UTC
Hmmm. Where do I get my X server log and config file? Also, how would
you suggest I get the log files from the failed boot? The screen is
blank and I have to use CTRL+ALT+DEL to get it to shut down since I
can't see anything on the screen. 

Comment 4 Eric Herman 2004-01-12 13:12:56 UTC
I updated to the 2135 (2138 and 2140) kernel and haven't seen the
problem since. Must have been a kernel issue..

Comment 5 Mike A. Harris 2004-01-12 16:51:33 UTC
Ok thanks.  Closing as ERRATA


Note You need to log in before you can comment on or make changes to this bug.