Bug 1118716 - Create app failed due to "Segmentation fault" while running rhc in ruby-1.8.7 env
Summary: Create app failed due to "Segmentation fault" while running rhc in ruby-1.8.7...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jessica Forrester
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 10:26 UTC by weiwei jiang
Modified: 2016-10-30 22:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-12 01:24:24 UTC


Attachments (Terms of Use)

Description weiwei jiang 2014-07-11 10:26:09 UTC
Description of problem:
when Creating app, sometimes failed due to the following message: 
rhc app create atgrwjve php-5.3 -g small --rhlogin libra-test+power7@redhat.com  --server stg.openshift.redhat.com
Application Options 
------------------- 
Domain: wda1cr 
Cartridges: php-5.3 
Gear Size: small 
Scaling: no 

Creating application 'atgrwjve' ... done 


Waiting for your DNS name to be available ... done 

/var/lib/gems/1.8/gems/open4-1.3.0/lib/open4.rb:243: [BUG] Segmentation fault 
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux] 

Aborted (core dumped) 

Version-Release number of selected component (if applicable):
rhc-1.27.4
ruby-1.8.7
open4-1.3.0
stg(devenv-stage_903)
devenv-stage_903

How reproducible:
Occasionally

Steps to Reproduce:
1.Create an app
2.
3.

Actual results:
rhc app create atgrwjve php-5.3 -g small --rhlogin libra-test+power7@redhat.com  --server stg.openshift.redhat.com
Application Options 
------------------- 
Domain: wda1cr 
Cartridges: php-5.3 
Gear Size: small 
Scaling: no 

Creating application 'atgrwjve' ... done 


Waiting for your DNS name to be available ... done 

/var/lib/gems/1.8/gems/open4-1.3.0/lib/open4.rb:243: [BUG] Segmentation fault 
ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux] 

Aborted (core dumped) 


Expected results:
Should success.

Additional info:

Comment 1 Jessica Forrester 2014-07-11 20:52:54 UTC
Can you try to catch this error while running the command with the --debug flag?   I suspect its probably failing when trying to start the process to run the git clone.


Note You need to log in before you can comment on or make changes to this bug.