Bug 1118760 - Upstream test "gkm/timer/cancel" fails: assertion failed: (timer != NULL)
Summary: Upstream test "gkm/timer/cancel" fails: assertion failed: (timer != NULL)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-keyring
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 13:16 UTC by Vadim Rutkovsky
Modified: 2015-03-05 08:49 UTC (History)
2 users (show)

Fixed In Version: gnome-keyring-3.8.2-10.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 08:49:41 UTC


Attachments (Terms of Use)
include upstream test change in packaging (2.39 KB, patch)
2014-08-15 14:45 UTC, David King
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0396 normal SHIPPED_LIVE gnome-keyring bug fix update 2015-03-05 13:48:37 UTC

Description Vadim Rutkovsky 2014-07-11 13:16:46 UTC
Description of problem:
gnome-keyring's testsuite fails on latest RHEL7 compose

Version-Release number of selected component (if applicable):
gnome-keyring-3.8.2-8.el7

How reproducible:
Always

Steps to Reproduce:
1. Run make check for gnome-keyring

Actual results:
See http://beaker.engineering.redhat.com/jobs/692223
[snip]
TEST: test-timer... (pid=32534)
  /gkm/timer/extra_initialize:                                         OK
  /gkm/timer/simple:                                                   OK
  /gkm/timer/cancel:                                                   **
ERROR:test-timer.c:98:test_cancel: assertion failed: (timer != NULL)
FAIL

Expected results:
All tests pass

Additional info:

Comment 2 David King 2014-08-15 14:45:09 UTC
Created attachment 927138 [details]
include upstream test change in packaging

There was a patch applied upstream which seems relevant:

https://git.gnome.org/browse/gnome-keyring/commit/?id=431939fcf6a2e81ab0b41db6d15a0316a97e1dfa

The attached patch includes the upstream patch in the package. Can you try the scratch build with the change in brew, and report back whether it fixes the problem or not?

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=7848780

Comment 3 Vadim Rutkovsky 2014-08-15 16:05:57 UTC
Yes, this test was fixed - see https://beaker.engineering.redhat.com/jobs/723241

Comment 5 Vadim Rutkovsky 2014-09-04 09:23:53 UTC
Verified, see https://beaker.engineering.redhat.com/jobs/736839

Comment 7 errata-xmlrpc 2015-03-05 08:49:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0396.html


Note You need to log in before you can comment on or make changes to this bug.