Bug 1118769 - Can't boot 3.15 kernel - Failed to start Reload Configuration from the Real Boot
Summary: Can't boot 3.15 kernel - Failed to start Reload Configuration from the Real Boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 13:40 UTC by Travis Paul
Modified: 2014-11-13 18:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-13 18:00:34 UTC


Attachments (Terms of Use)
dmesg from working 3.14.9 kernel (68.92 KB, text/plain)
2014-07-11 13:40 UTC, Travis Paul
no flags Details

Description Travis Paul 2014-07-11 13:40:14 UTC
Created attachment 917312 [details]
dmesg from working 3.14.9 kernel

Description of problem:

When selecting either the 3.15.3 or 3.15.4 kernels the system will not boot into a usable operating system.

Version-Release number of selected component (if applicable):
Kernel 3.15.3 and 3.15.4 

How reproducible:
Always

Steps to Reproduce:
1. Select the 3.15.3 (or 3.15.4) kernel at the grub menu

Actual results:

[OK] Reached Target initrd Root File System
     Starting Reload Configuration from Real Boot
[36.823652] usb 1-1.1: stat urb: killed, stream 0
[70.904537] usb 1-1.1: stat urb: killed, stream 0
[FAILED] Failed to start Reload Configuration fomr the Real Boot.
See 'systemctl status initrd-parse-etc.service' for details.

Generating "/run/initramfs/rdsosreport.txt"
[104.854437] usb 1-1.1: stat urb: killed, stream 0

Expected results:

System to boot normally which happens with the 3.14.9 kernel

Additional info:

System boots off of an external USB Hard drive, home partition is encrypted I am never prompted for my encryption password with the 3.15 kernels.

Attached is dmesg output from running 3.14.9 kernel.

Comment 1 David Harmanec 2014-07-12 19:46:18 UTC
I am having the same problem. (My configuration: only boot partition is not encrypted, encrypted lvm volume with all other partitions, Lenovo R400).

When attepmting to boot both versions of 3.15 kernel screen goes blank. I am never prompted for the disk encryption passphrase. Version 3.14 worked just fine.

Comment 2 Mark Palmeri 2014-07-18 03:44:58 UTC
Same problem with kernels 3.15.[3-5], with system turning itself off.  Using LVM with encrypted /home partition, Dell Precision T3600.  3.14.x kernels all work fine.

Comment 3 jmb 2014-07-19 10:15:17 UTC
3.13.6-200 fc20.x86_64 - OK
3.15.4-200 fc20.x86_64 - Not OK
3.15.5-200 fc20.x86_64 - Not OK

No Encryption, external USB hard drive, base platform is a HP 6530b

Comment 4 Martin Gregorie 2014-07-25 16:09:31 UTC
I am having the same problem with kernel 3.15.6.200 on a Lenovo R61i. After this version failed to boot three times I went back to the previous kernel (3.15.5.200), which doesn't have this problem. I did not thhe problems booting 3.15.4.200 either. Here is the relevant part of /var/log/message:

Jul 25 16:16:58 zappa kernel: Console: switching to colour frame buffer device 160x50
Jul 25 16:16:58 zappa kernel: i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
Jul 25 16:16:58 zappa kernel: i915 0000:00:02.0: registered panic notifier
Jul 25 16:16:58 zappa kernel: ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)
Jul 25 16:16:58 zappa kernel: acpi device:01: registered as cooling_device2
Jul 25 16:16:58 zappa kernel: input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input7
Jul 25 16:16:58 zappa kernel: [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
Jul 25 16:16:58 zappa systemd: Started dracut initqueue hook.
Jul 25 16:16:58 zappa systemd: Starting dracut pre-mount hook...
Jul 25 16:16:58 zappa kernel: PM: Starting manual resume from disk
Jul 25 16:16:58 zappa systemd: Started dracut pre-mount hook.
Jul 25 16:16:58 zappa systemd: Mounting /sysroot...
Jul 25 16:16:58 zappa systemd: Received SIGRTMIN+20 from PID 224 (plymouthd).
Jul 25 16:16:58 zappa systemd: Started Show Plymouth Boot Screen.
Jul 25 16:16:58 zappa systemd: Started Dispatch Password Requests to Console Directory Watch.
Jul 25 16:16:58 zappa systemd: Starting Paths.
Jul 25 16:16:58 zappa systemd: Reached target Paths.
Jul 25 16:16:58 zappa systemd: Starting Forward Password Requests to Plymouth Directory Watch.
Jul 25 16:16:58 zappa systemd: Started Forward Password Requests to Plymouth Directory Watch.
Jul 25 16:16:58 zappa systemd: Starting Basic System.
Jul 25 16:16:58 zappa systemd: Reached target Basic System.
Jul 25 16:16:58 zappa systemd: Mounted /sysroot.
Jul 25 16:16:58 zappa systemd: Starting Initrd Root File System.
Jul 25 16:16:58 zappa systemd: Reached target Initrd Root File System.
Jul 25 16:16:58 zappa systemd: Starting Reload Configuration from the Real Root...
Jul 25 16:16:58 zappa systemd: Reloading.
Jul 25 16:16:58 zappa kernel: EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
Jul 25 16:16:58 zappa systemd: Started Reload Configuration from the Real Root.
Jul 25 16:16:58 zappa systemd: Starting Initrd File Systems.
Jul 25 16:16:58 zappa systemd: Reached target Initrd File Systems.
Jul 25 16:16:58 zappa systemd: Started dracut mount hook.
Jul 25 16:16:58 zappa systemd: Starting Initrd Default Target.
Jul 25 16:16:58 zappa systemd: Reached target Initrd Default Target.
Jul 25 16:16:58 zappa systemd: Starting dracut pre-pivot and cleanup hook...
Jul 25 16:16:58 zappa systemd: Started dracut pre-pivot and cleanup hook.

Getting SIGRTMIN+20 from plymouthd seems to have happened in all three boot attempts before "Started Reload Configuration from the Real Root" was logged.

Comment 5 Martin Gregorie 2014-07-26 17:14:58 UTC
I'm unsure if its relevant[*] but during the failed boot, after the white patch turned into the F symbol and flashed and the screen had been cleared the message:

[drm:i965_irq_handler] *ERROR* pipe A underrun ...:

appeared at the top left of the screen for a few seconds before the screen was again blanked.  

[*] this has been happening for a few kernel releases but since, after a second or two, the the login prompt screen appeared I'd been ignoring it. But, with kernel 3.15.6.200 the screen just stayed black as the boot failed.

Comment 6 Justin M. Forbes 2014-11-13 15:58:03 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.

Comment 7 Martin Gregorie 2014-11-13 17:05:35 UTC
It hasn't been an issue here since 3.16.* was current.


Note You need to log in before you can comment on or make changes to this bug.