Bug 111881 - usb-storage device is not detected
usb-storage device is not detected
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: modutils (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 02:26 EST by Behdad Esfahbod
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version: 2.4.26-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-09 11:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2003-12-11 02:26:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
With 2.4 kernel, I load sg and usb-storage modules, and my USB memory
is detected as sdc.  But now with rawhide's 2.6 kernel it is not detected.

Actually it's not just the USB memory that is not detected.  Usually
when I do cdrecord -scanbus, I get three devices, a CD/DVD burner, a
Sony MemStick reader, and my USB flash memory.

Now with 2.6, I just see the burner, no memory reader and no USB
memory.  I'm almost sure that this work under 2.6, perhaps I need
another module now?  I get absolutely nothing in logs or dmesg when I
plug or unplug my flash.


Version-Release number of selected component (if applicable):
2.6.0-0.test11.1.12

How reproducible:
Always

Steps to Reproduce:
1. NA
2.
3.
    

Additional info:
Comment 1 Arjan van de Ven 2003-12-11 02:38:11 EST
can you see if kudzu loaded the usb host controller modules ?
Comment 2 Behdad Esfahbod 2003-12-11 04:53:39 EST
I've got my USB mouse working.  And here is a list of modules loaded:

Module                  Size  Used by
p4_clockmod             4232  0
freq_table              4228  1 p4_clockmod
usb_storage            57152  0
sg                     32536  0
md5                     3840  1
ipv6                  214208  12
iptable_filter          2688  0
ip_tables              16000  1 iptable_filter
e100                   55048  0
microcode               6304  0
sr_mod                 15396  0
ide_scsi               13316  0
ide_cd                 36484  0
cdrom                  31904  2 sr_mod,ide_cd
ohci1394               30600  0
ieee1394              212780  1 ohci1394
nls_utf8                2048  1
nls_cp437               5632  1
vfat                   13312  1
fat                    41024  1 vfat
sd_mod                 15392  0
scsi_mod              109240  5 usb_storage,sg,sr_mod,ide_scsi,sd_mod
hid                    57152  0
usbcore                96604  3 usb_storage,hid
thermal                13200  0
processor              14244  1 thermal
fan                     4108  0
button                  6168  0
battery                 9740  0
asus_acpi              10136  0
ac                      4876  0
radeon                106284  2
radeonfb               22408  0
ext3                  102440  3
jbd                    50200  1 ext3
dm_mod                 36128  0
Comment 3 Arjan van de Ven 2003-12-11 06:25:33 EST
uhci-hcd.ko  seems to be missing (eg not loaded)....
Comment 4 Pete Zaitcev 2004-01-07 14:59:46 EST
One super annoying place which makes autoswitching between
2.4 and 2.6 is UHCI HC driver.

[root@pentabug zaitcev]# cat /etc/modules.conf
alias eth0 3c59x
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :
# 2.4 MUST use this
#alias usb-controller usb-uhci
# 2.6 MUST use this
alias usb-controller uhci-hcd
# Hmm. Doesn't work too well for some reason...
#alias uhci_hcd uhci-hcd
# Extras
#alias usb-controller1 usb-ohci
[root@pentabug zaitcev]#

If Behdad confirms that root cause matches,
it's a WONTFIX material. I do not see an easy way to
work this in kernel. Alternatively, bounce this to initscrips
and let Notting add another if [];.

Needinfo-ing to prompt Behdad.
Comment 5 Behdad Esfahbod 2004-01-09 11:30:41 EST
It's fixed in current modutils by adding these lines to
/etc/modprobe.conf.dist:

alias usb-uhci uhci-hcd
alias usb-ohci ohci-hcd
alias uhci uhci-hcd

I tested and worked.

Note You need to log in before you can comment on or make changes to this bug.