Bug 1118820 - [RFE] Be able to search subscirptions based on their repositories
Summary: [RFE] Be able to search subscirptions based on their repositories
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
: 979185 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 15:26 UTC by Bryan Kearney
Modified: 2019-08-12 14:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:11:32 UTC


Attachments (Terms of Use)

Description Bryan Kearney 2014-07-11 15:26:21 UTC
Request is for the ability to list out available products _AND_ their repositories:

Something akin to:

hat said, if there was some really verbose mode that would show all the products, what they provide *AND* the repos it would be awesome:

# subscription-manager list --available --all --repos
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

Subscription Name: Red Hat Satellite Employee Subscription
Provides:          Red Hat Beta
                   Red Hat Satellite Tools 6 MDP
                   Red Hat Satellite 6 MDP
                   Red Hat Satellite Capsule 6 Beta
                   Oracle Java (for RHEL Server)
                   Red Hat Satellite 6 Beta
                   Red Hat Enterprise Linux High Availability (for RHEL Server)
                   Red Hat Enterprise Linux Server
                   Red Hat Satellite
                   Red Hat Enterprise Linux Load Balancer (for RHEL Server)
SKU:               SER0232US
Pool ID:           8a85f9813f14fe33013f81b33d910c87
Available:         684
Suggested:         1
Service Level:     Self-Support
Service Type:      L1-L3
Multi-Entitlement: No
Ends:              01/01/2022
System Type:       Virtual
Repos:

Repo ID:   rhel-lb-for-rhel-6-server-eus-rpms
Repo Name: Red Hat Enterprise Linux Load Balancer (for RHEL 6 Server) - Extended Update Support (RPMs)
Repo URL: https://cdn.redhat.com/content/eus/rhel/server/6/$releasever/$basearch/loadbalancer/os
Enabled:   1

Repo ID:   rhel-6-server-rhs-client-1-source-rpms
Repo Name: Red Hat Storage Native Client for RHEL 6 (Source RPMs)
Repo URL: https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/rhs-client/source/SRPMS
Enabled:   0

Repo ID:   rhel-6-server-extras-source-rpms
Repo Name: Red Hat Enterprise Linux 6 Server - Extras (Source RPMs)
Repo URL: https://cdn.redhat.com/content/dist/rhel/server/6/6Server/$basearch/extras/source/SRPMS
Enabled:   0

Repo ID:   rhel-6-server-ose-2-beta-node-debug-rpms
Repo Name: Red Hat OpenShift Enterprise 2 Application Node Beta (Debug RPMs)
Repo URL: https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/ose-node/2/debug
Enabled:   0

Repo ID:   rhel-6-server-ose-2.0-infra-rpms
Repo Name: Red Hat OpenShift Enterprise 2.0 Infrastructure (RPMs)
Repo URL: https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/ose-infra/2.0/os
Enabled:   0

Repo ID:   rhel-6-server-optional-debug-rpms
Repo Name: Red Hat Enterprise Linux 6 Server - Optional (Debug RPMs)
Repo URL: https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/optional/debug
Enabled:   0

..

Comment 1 Mike McCune 2014-07-11 15:29:40 UTC
The only way now to find a specific repository you need access to is repeatedly attach/delete subscriptions and use the 'repos' command to find the one that contains the one you are looking for.

Comment 3 Bryan Kearney 2014-07-30 19:23:27 UTC
Acking 7.1

Comment 4 Devan Goodwin 2014-10-08 12:54:08 UTC
*** Bug 979185 has been marked as a duplicate of this bug. ***

Comment 5 Devan Goodwin 2014-10-08 12:56:05 UTC
Marked a bug above as a duplicate of this, it is requesting similar functionality but for display purposes rather than search, both will be solved by the same implementation.

Some thoughts from an email on this:

This blends with another shortcoming we have in candlepin where changes to content sets on an engineering product do not trigger any regenerated entitlements during refresh pools.

The reason for both is because we simply do not store a representation of content on the pool, so we have nothing to compare to to see if something changed.

Fixing this would involved:

- enhancing PoolProvidedProduct to map to PoolContent (or something similar)
- update refresh pools to copy this data off subscription
- update refresh pools to compare this data and flag to regenerate entitlements if anything changes
- figure out how to display this in subman CLI and GUI. It might be too much data to send by default with the pool, but who knows.
- expose a mechanism to search for content

End result, pool refresh in hosted would get slower as we now have to lookup product content for each eng product as we go. But then bind in hosted would get faster, as we no longer have to do this. Satellite would stay the same.

We would then be setting ourselves up nicely to allow people to search for a content set, and someday possibly hook up with pulp to let users query the rpms in each content set, all without having to attach the subscription beforehand.



Feature is large so we're deferring to 6.7.

Comment 6 John Sefler 2014-10-28 17:45:34 UTC
This feature request was not implemented and delivered to QE by the rhel-7.1.0 Dev Freeze date of 10/27/2014.  Deferring for consideration in next release.

Comment 8 Adrian Likins 2015-05-06 18:18:16 UTC
I think for subscription.rhn.redhat.com, it might be useful to eventually support a "ContentServiceAdapter" in candlepin. With the adapter providing some lookup/search api for content.

In my head, the backend to a ContentServiceAdapter is something like a elasticsearch server, with content labels, names, product ids and names, and even package info. So a candlepin could answer 'what subscription provides redhat-release-7.1.0'. That means new candlepin api, new client, a content service adapter interface and implementation. 

We might not need the whole search interface, but at the moment, we don't know anything about the repos associated with a product, so we need at least some info.

Comment 10 Devan Goodwin 2015-05-07 11:36:35 UTC
Will be possible with Candlepin 1.0. List --matches should just start working against yum repo labels once we hook it all up, and I don't think it will require client changes other than to perhaps display what matched.

Comment 11 Kevin Howell 2018-02-22 16:00:34 UTC
We'd like to evaluate this RFE for Satellite.

Comment 12 Bryan Kearney 2018-09-04 18:59:36 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 13 Bryan Kearney 2018-09-04 19:11:32 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.