Bug 1118826 - Rubygem-Staypuft: Neutron deployment gets stuck on 20%.
Summary: Rubygem-Staypuft: Neutron deployment gets stuck on 20%.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ga
: 5.0 (RHEL 7)
Assignee: Jason Guiditta
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 15:46 UTC by Alexander Chuzhoy
Modified: 2014-09-08 05:44 UTC (History)
5 users (show)

Fixed In Version: openstack-foreman-installer-2.0.14-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:35:48 UTC


Attachments (Terms of Use)
/var/log/neutron/server.log from the neutron controller. (6.11 KB, text/x-log)
2014-07-11 15:46 UTC, Alexander Chuzhoy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1003 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-04 22:31:07 UTC

Description Alexander Chuzhoy 2014-07-11 15:46:51 UTC
Created attachment 917371 [details]
/var/log/neutron/server.log from the neutron controller.

Rubygem-Staypuft:  Neutron deployment gets stuck on 20%.

Environment:
rhel-osp-installer-0.1.0-2.el6ost.noarch
ruby193-rubygem-staypuft-0.1.11-1.el6ost.noarch
openstack-foreman-installer-2.0.13-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-7.el6ost.noarch
openstack-puppet-modules-2014.1-18.1.el6ost.noarch

Steps to reproduce:
1. Install rhel-osp-installer
2. Create a neutron deployment with 3 hosts (1 controller +1 networker +1 compute)
3. Set the "Tenant Netwotk Type" to "VLAN Segmentation".
4. Set the "Tenant (VM data) VLAN Ranges" to "int_vlan_range:216:217,int_vlan_range:192:192"
5. Start the deployment.


Results: Neutron deployment gets stuck on 20%.In the "more details" page - I see that it's stuck on 60% installing the Neutron controller.
Manually running the puppet agent on the Neutron controller - I see this:
Error: Could not start Service[neutron-server]: Execution of '/sbin/service neutron-server start' returned 1:                                                   
Error: /Stage[main]/Neutron::Server/Service[neutron-server]/ensure: change from stopped to running failed: Could not start Service[neutron-server]: Execution of '/sbin/service neutron-server start' returned 1: 

Expected result: Deployment completed 100%.

Comment 3 Alexander Chuzhoy 2014-07-11 16:14:46 UTC
The yaml output for the controller is in the link:
http://pastebin.test.redhat.com/221069

Comment 4 Crag Wolfe 2014-07-11 18:11:38 UTC
I'd suggest for debugging purposes adding "vlan" to the ml2_type_drivers parameter and retrying puppet on the controller.

Comment 5 Alexander Chuzhoy 2014-07-11 23:45:31 UTC
Changed it from ["vxlan","flat"] to ["vxlan","flat","vlan"] and reran puppet on the node.
Still fails with the same error. The changes/errors are below.

Info: Applying configuration version '1405121948'
Notice: /Stage[main]/Quickstack::Swift::Proxy/Quickstack::Rsync::Simple[swift_server]/Exec[restart-xinetd-swift_server]/returns: executed successfully
Notice: /Stage[main]/Ceilometer::Keystone::Auth/Keystone_user_role[ceilometer@services]/roles: roles changed ['ResellerAdmin', 'admin'] to 'admin ResellerAdmin'
Notice: /Stage[main]/Neutron::Plugins::Ml2/Neutron_plugin_ml2[ml2/type_drivers]/value: value changed 'vxlan,flat' to 'vxlan,flat,vlan'
Info: /Stage[main]/Neutron::Plugins::Ml2/Neutron_plugin_ml2[ml2/type_drivers]: Scheduling refresh of Service[neutron-server]
Notice: /Stage[main]/Neutron::Plugins::Ml2/Neutron::Plugins::Ml2::Driver[vlan]/Neutron_plugin_ml2[ml2_type_vlan/network_vlan_ranges]/ensure: created
Info: /Stage[main]/Neutron::Plugins::Ml2/Neutron::Plugins::Ml2::Driver[vlan]/Neutron_plugin_ml2[ml2_type_vlan/network_vlan_ranges]: Scheduling refresh of Service[neutron-server]
Notice: /Stage[main]/Neutron::Server::Notifications/Nova_admin_tenant_id_setter[nova_admin_tenant_id]/ensure: created
Notice: /Stage[main]/Quickstack::Neutron::Controller/Exec[neutron-db-manage upgrade]/returns: executed successfully
Error: Could not start Service[neutron-server]: Execution of '/sbin/service neutron-server start' returned 1:
Error: /Stage[main]/Neutron::Server/Service[neutron-server]/ensure: change from stopped to running failed: Could not start Service[neutron-server]: Execution of '/sbin/service neutron-server start' returned 1:
Notice: /Stage[main]/Neutron::Server/Service[neutron-server]: Triggered 'refresh' from 2 events
Notice: Finished catalog run in 55.09 seconds

Comment 6 Jason Guiditta 2014-07-14 13:58:26 UTC
OK, looking at your log posted above as well as the yaml output from foreman, it looks to me like there error is @ line 95/96:
    ml2_type_drivers:
    - vxlan

The output in the log says:

2014-07-11 15:24:32.639 19494 INFO neutron.plugins.ml2.managers [-] Registered types: ['flat', 'vxlan']
2014-07-11 15:24:32.640 19494 ERROR neutron.plugins.ml2.managers [-] No type driver for tenant network_type: vlan. Service terminated!

So you probably just need to set vlan instead of vxlan in your ml2_type_drivers (you have it only in ml2_tenant_network_types currently)

Comment 7 Jason Guiditta 2014-07-14 16:16:10 UTC
Patch posted:

https://github.com/redhat-openstack/astapor/pull/310

Comment 8 Jason Guiditta 2014-07-14 16:16:46 UTC
Merged

Comment 12 Alexander Chuzhoy 2014-08-01 15:35:38 UTC
Verified: rhel-osp-installer-0.1.6-5.el6ost.noarch

the deployment completed 100% without any intervention.

Note: At the time I was also selecting a vlan range that was too big, and might have used the wrong interfaces for tenant/external networks.

Comment 13 errata-xmlrpc 2014-08-04 18:35:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1003.html


Note You need to log in before you can comment on or make changes to this bug.