Bug 111884 - Tool converts hex numbers to deciaml
Tool converts hex numbers to deciaml
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 02:46 EST by Ron Sokoloski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 08:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Sokoloski 2003-12-11 02:46:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I was installing a DE220 network card in a friends firewall. This card
uses the legacy ne driver, which needs the io address and irq supplied
in an 'options' line in modules.conf.

I tried the network tool in gui mode, but it refused to load when I
set the irq to 10 and the io address to 0x300. Doing "modprobe ne
io=0x300 irq=10" from the command line worked, however. I opened
modules.conf in vi, and found the following:

alias eth1 ne
options ne irq=10 io=12c

12c is 300 in hex. Manually changing it to 

alias eth1 ne
options ne irq=10 io=0x300

fixed the problem.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.Install NE1000/2000 hardware
2.use the graphical redhat-config-network tool to try and set the IO
address of the card to a hex number, like 0x300
3.Save the config. The driver fails to load
   

Actual Results:  Driver refused to load, since the io was set to 0x12c
not 0x300

Expected Results:  NE*000 ethercard probe at 0x300: 00 80 c8 2c f1 a5
eth1: NE2000 found at 0x300, using IRQ 10.


Additional info:
Comment 1 Harald Hoyer 2004-01-29 09:47:39 EST
did you enter "0x300" or "300" in the io entry? if you mean hex, you
should prefix with "0x", 
Comment 2 Ron Sokoloski 2004-01-29 18:48:07 EST
Hi, Harold.

I did prefix it - I entered 0x300 (without quotes of course)in the I/O
entry. I tried that 3 times just to make sure before I knew it was a
bug and not user error.

Ron

Note You need to log in before you can comment on or make changes to this bug.