Bug 1118840 - Block live migration to fails in packstack deployment
Summary: Block live migration to fails in packstack deployment
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: RDO
Classification: Community
Component: openstack-packstack
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Martin Magr
QA Contact: Gabriel Szasz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 16:26 UTC by Gabriel Szasz
Modified: 2014-11-04 13:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 13:08:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1340833 None None None Never

Description Gabriel Szasz 2014-07-11 16:26:56 UTC
Description of problem:

Block live migration in Packstack deployment does not work without workaround.


Version-Release number of selected component (if applicable):
openstack-packstack-2014.1.1-0.32.1.dev1209.el7ost


How reproducible:
100%


Steps to Reproduce:
1. Deploy RHOS 5 in three-node setup (1 controller / 2 compute nodes) by Packstack on RHEL 7

      # packstack --install-hosts=${controller_ip},${node1_ip},${node2_ip} \
          --nagios-install=n \
          --os-ceilometer-install=n \
          --os-neutron-install=n \
          --novanetwork-pubif=${controller_if} \
          --novanetwork-privif=${controller_if} \
          --novacompute-privif=${node1_if} \
          --keystone-admin-passwd=redhat \
          --keystone-demo-passwd=redhat \
          --ssh-public-key=/root/.ssh/id_rsa.pub

2. Convince yourself that both compute nodes have the same CPUs and are connected to the network with the same network interfaces.

3. Add following line to /etc/nova/nova.conf on both compute nodes:

live_migration_flag=VIR_MIGRATE_UNDEFINE_SOURCE,VIR_MIGRATE_PEER2PEER,VIR_MIGRATE_LIVE

4. Restart openstack-nova-compute service on both compute nodes.

5. Run following commands on controller:

    # source keystonerc_admin
    # nova keypair-add --pub-key ~/.ssh/id_rsa root
    # nova boot --flavor m1.small --image cirros test --key_name root

6. Check the compute node on which was the instance spawned. In the next step use the other compute node as target host.

7. Run command:

    # nova live-migration --block-migrate test ${target_node}
Actual results:
CLI displays no error, but the instance is not migrated. Following error message appears in /var/log/nova-compute.log on the source compute node.

2014-07-08 16:59:23.894 28674 ERROR nova.virt.libvirt.driver [-] [instance: 61fe562c-7879-49c8-84b9-b100445414aa] Live Migration failure: operation failed: Failed to connect to remote libvirt URI qemu+ssh://nova@cloud-qe-15.idm.lab.bos.redhat.com/system?no_verify=1&keyfile=/etc/nova/ssh/nova_migration_key: packet 1416128879 bytes received from server too large, want 16777216

Expected results:
Instance is migrated to the target host. No errors appear in log

Additional info:

The actual workaround is to replace /sbin/nologin shell for nova user on tharget node by /bin/bash.

The issue is related to the configuration made by Packstack.

Comment 1 Gabriel Szasz 2014-11-04 13:08:12 UTC
I originally filed this bug as RDO counterpart of the Launchpad 1340833. As I understand now, my effort was completely redundant.

The reported issue was already fixed in the upstream and the fix was delivered to RDO.


Note You need to log in before you can comment on or make changes to this bug.