Bug 1118894 - Receive HTTP 200 after creating architecture, not HTTP 201
Summary: Receive HTTP 200 after creating architecture, not HTTP 201
Keywords:
Status: CLOSED DUPLICATE of bug 1118015
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 19:58 UTC by jaudet
Modified: 2019-02-25 21:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 13:48:04 UTC


Attachments (Terms of Use)

Description jaudet 2014-07-11 19:58:24 UTC
Description of problem:
After issuing a successful HTTP POST to api/v2/architectures, an HTTP 200 response is received. An HTTP 201 should be received.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Issue an HTTP POST request to api/v2/architectures path and specify all required fields.
2. Save response.
3. Examine status code of response received.

Actual results:
HTTP 200 status code.

Expected results:
HTTP 201 status code.

Additional info:
This bug is extremely similar to #1118015.

A pull request with the relevant tests is in progress. Before the PR is accepted, you can view the tests here [1], and after the PR is accepted, you can view the tests here [2].

[1] https://github.com/omaciel/robottelo/blob/master/tests/foreman/api/test_architecture_v2.py#L46-L68
[2] https://github.com/omaciel/robottelo/blob/master/tests/foreman/api/test_multiple_paths.py#L54-L83

Comment 1 jaudet 2014-07-11 20:01:22 UTC
I forgot to attach info about version numbers. Here:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.21-1.el6sat.noarch
* foreman-compute-1.6.0.21-1.el6sat.noarch
* foreman-gce-1.6.0.21-1.el6sat.noarch
* foreman-libvirt-1.6.0.21-1.el6sat.noarch
* foreman-ovirt-1.6.0.21-1.el6sat.noarch
* foreman-postgresql-1.6.0.21-1.el6sat.noarch
* foreman-proxy-1.6.0.9-1.el6sat.noarch
* foreman-selinux-1.6.0-5.el6sat.noarch
* foreman-vmware-1.6.0.21-1.el6sat.noarch
* katello-1.5.0-26.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.53-1.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 2 RHEL Product and Program Management 2014-07-11 20:04:22 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 jaudet 2014-07-17 13:48:04 UTC
This bug is nearly identical to #1118015. Closing this one and updating the other.

*** This bug has been marked as a duplicate of bug 1118015 ***


Note You need to log in before you can comment on or make changes to this bug.