Bug 1118911 - Install of tlp on CentOS 7 x64 fails, missing dependancy
Summary: Install of tlp on CentOS 7 x64 fails, missing dependancy
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tlp
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jeremy Newton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-11 22:08 UTC by Steve Dainard
Modified: 2014-07-11 23:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-11 23:20:48 UTC


Attachments (Terms of Use)

Description Steve Dainard 2014-07-11 22:08:22 UTC
Description of problem:

Attempting to install tlp produces this error:

# yum install tlp
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.nexicom.net
 * epel: www.muug.mb.ca
 * extras: centos.mirror.nexicom.net
 * updates: centos.mirror.nexicom.net
Resolving Dependencies
--> Running transaction check
---> Package tlp.noarch 0:0.5-2.el7 will be installed
--> Processing Dependency: wireless-tools for package: tlp-0.5-2.el7.noarch
--> Processing Dependency: hdparm for package: tlp-0.5-2.el7.noarch
--> Running transaction check
---> Package hdparm.x86_64 0:9.43-5.el7 will be installed
---> Package tlp.noarch 0:0.5-2.el7 will be installed
--> Processing Dependency: wireless-tools for package: tlp-0.5-2.el7.noarch
--> Finished Dependency Resolution
Error: Package: tlp-0.5-2.el7.noarch (epel)
           Requires: wireless-tools
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]# yum search wireless-tools
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.nexicom.net
 * epel: www.muug.mb.ca
 * extras: centos.mirror.nexicom.net
 * updates: centos.mirror.nexicom.net
Warning: No matches found for: wireless-tools
No matches found

The rpm from here for CentOS 6.5 satisfies the dependency: http://www.rpmfind.net/linux/rpm2html/search.php?query=wireless-tools

Comment 1 Jeremy Newton 2014-07-11 23:20:48 UTC
This is not a bug with TLP per say... The package seems to be missing from CentOS 7, which is not the responsibility of the EPEL team.

Please report this as a bug to CentOS, as wireless-tools is required for this package to function.

If this cannot be resolved by the CentOS team and is in fact an issue with RHEL 7 , which is the code base for CentOS, then please file a bug against RHEL 7, which can be done at the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207

If this is truly the case, please CC me on the bug or forward it to me, so I can help get this resolved as quickly as possible.

Unfortunately, because this is not a bug with TLP, I will be closing this issue, sorry. Feel free to keep in touch if you need help.


Note You need to log in before you can comment on or make changes to this bug.