Bug 111893 - nfs service on cluster is not started on ES 3 with clumanager-1.2.3-1
nfs service on cluster is not started on ES 3 with clumanager-1.2.3-1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jim Parsons
James Laska
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 06:00 EST by Nguyen Ngoc Can
Modified: 2013-09-02 01:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 16:16:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
see this joined file (1.36 KB, text/plain)
2003-12-11 11:57 EST, Nguyen Ngoc Can
no flags Details

  None (edit)
Description Nguyen Ngoc Can 2003-12-11 06:00:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.2.1)
Gecko/20030225

Description of problem:
The Goal is making nfs service running on cluster (ES 3)

1. When creating NFS service with cluster-config (with nfs druid) i
got this error message in /var/log/messages

service error : StartStopNFS : Failed restarting nfs daemon :
/usr/lib/clumanager/services/services : line 64 : Arr�t : Command not
found

service error : StartStopNFS : Failed restarting nfs daemon :
/usr/lib/clumanager/services/services : line 65 : Demarrage : Command
not found

service error : can not stop NFS ...

nb : I used French Keyboard, that mean Arr�t = stop, Demarrage = start

2. When creating NFS service with cluster-manager (not with druid, but
like generic service ... "new service, add ip adress, add special
device etc ...."  

result :

when starting nfs service bye "clusvcadm -e nfs-service" on one node1,
it's ok with clustat (i saw nfs-service started on node1, but
clumanager did not really start nfsd daemon when i execute "ps -ef |
grep -i nfs"

nb : i use "None" in user script field (i did not use /etc/init.d/nfs)

3. the the same test than 2. but i used /etc/init.d/nfs

result :

when starting nfs service bye "clusvcadm -e nfs-service" on one node1,
clustat tell me that nfs-service failed (node1) ... But when "ps -ef
|grep -i nfs" i saw all nfsd daemon present .... !!!!

Could you please tell me if it's really a bug ?? and give me
informations that allow me to use NFS with clumanager ....

thank you very much ... customer's waiting for our informations

Can


Version-Release number of selected component (if applicable):
clumanager-1.2.3-1 and redhat-config-cluster-1.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. creating NFS service with clumanager (cluster-config tool)
2. starting nfs service
3. clustat to see result
    

Actual Results:  nfs service can not be started and not available

Expected Results:  nfs service will be started by clumanager
(clusvcadm -e nfs-service)

Additional info:

clumanager-1.2.3-1 and redhat-config-cluster-1.0.1-2 are used
Comment 1 Nguyen Ngoc Can 2003-12-11 11:57:19 EST
Created attachment 96472 [details]
see this joined file
Comment 2 Lon Hohberger 2003-12-11 13:30:26 EST
To configure NFS services, you should have the NFS daemons always
running on both members.  The cluster manages the exports; it should
not start & stop the NFS servers themselves.

On all cluster members, run:

# chkconfig --level 2345 nfs on
# chkconfig --level 2345 nfslock on
# service nfs start
# service nfslock start

For NFS services under Cluster Manager, you do not need to specify a
user script.

Comment 3 Lon Hohberger 2003-12-11 13:33:30 EST
That is to say: Unlike, for instance, Samba, the NFS daemons are in
the kernel.  They can not be bound to a specific IP address in the way
Samba and other services can.

Suppose you have a machine which serves both clustered and
non-clustered NFS exports - stopping or restarting the NFS daemons
inside of Cluster Manager would break all of your non-cluster exports,
a very bad thing!

Comment 4 Suzanne Hillman 2004-04-14 16:16:56 EDT
As it has been over 4 months since the last comment, I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.