Bug 1118933 - configure: error: cannot run C compiled programs
Summary: configure: error: cannot run C compiled programs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 02:58 UTC by Lokesh Mandvekar
Modified: 2014-07-13 14:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-13 14:08:33 UTC


Attachments (Terms of Use)
config.log (9.83 KB, text/plain)
2014-07-12 02:58 UTC, Lokesh Mandvekar
no flags Details

Description Lokesh Mandvekar 2014-07-12 02:58:46 UTC
Created attachment 917467 [details]
config.log

Description of problem:

I'm trying to build libressl on rawhide, but running the configure script gives an error 

But ./configure seems to work well in my f20 container.

Version-Release number of selected component (if applicable):
gcc-4.9.0-14.fc21.x86_64


How reproducible: always


Steps to Reproduce:
1. fetch http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.0.0.tar.gz , extract and cd
2. ./configure
3. see error

Actual results:

$ ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... configure: error: in `/home/lsm5/repositories/pkgs/fedora/libressl/libressl-2.0.0':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

Comment 1 Robert Scheck 2014-07-12 17:44:48 UTC
[...]
configure:3453: gcc -o conftest  -Wall -Werror -std=c99 -g -Wno-pointer-sign -D_BSD_SOURCE -D_POSIX_SOURCE -D_GNU_SOURCE   conftest.c  >&5
In file included from /usr/include/stdio.h:27:0,
                 from conftest.c:11:
/usr/include/features.h:148:3: error: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Werror=cpp]
 # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
   ^
cc1: all warnings being treated as errors
[...]

Remove either -Werror from configure or correct the reason for warning. This
is not a GCC issue IMHO.

Comment 2 Lokesh Mandvekar 2014-07-13 14:08:33 UTC
(In reply to Robert Scheck from comment #1)
> [...]
> configure:3453: gcc -o conftest  -Wall -Werror -std=c99 -g -Wno-pointer-sign
> -D_BSD_SOURCE -D_POSIX_SOURCE -D_GNU_SOURCE   conftest.c  >&5
> In file included from /usr/include/stdio.h:27:0,
>                  from conftest.c:11:
> /usr/include/features.h:148:3: error: #warning "_BSD_SOURCE and _SVID_SOURCE
> are deprecated, use _DEFAULT_SOURCE" [-Werror=cpp]
>  # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
>    ^
> cc1: all warnings being treated as errors
> [...]
> 
> Remove either -Werror from configure or correct the reason for warning. This
> is not a GCC issue IMHO.

Yup, upstream libressl took care of this in 2.0.1. Closing this, thanks!


Note You need to log in before you can comment on or make changes to this bug.