Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 111894 - kernel panic Attempted to kill init
kernel panic Attempted to kill init
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 07:45 EST by Need Real Name
Modified: 2015-01-04 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-19 10:31:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-12-11 07:45:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
While booting kernel-2.4.22-1.2115.nptlsmp on a compaq proliant DL580 
with 4 intel xeon processors and 2 gig of memory I receive the 
following message:

<0>kernel panic: Attempted to kill init

At this point the system in hung.  To restart I have to power off and 
power back on.

If I boot kernel-2.4.22-1.2115.nptl no smp the system boots fine.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2115.nptlsmp

How reproducible:
Always

Steps to Reproduce:
1. Boot the smp kernel
2.
3.
    

Additional info:
Comment 1 Dave Jones 2003-12-11 14:15:28 EST
Please try and repeat this with the errata kernel.
Comment 2 Need Real Name 2003-12-11 15:21:36 EST
Where do I get this kernel for fedora core 1
Comment 3 Dave Jones 2003-12-12 09:15:27 EST
up2date -fu
Comment 4 Need Real Name 2003-12-16 08:57:40 EST
Installed Fedora kernel 2.4.22-1.2129.nptlsmp.

Received the same result.

I did get more information

Kernel bug at smpboot.c.1107!
Invalid operand:0000

<0> kernel panic: Attempted to kil init
Comment 5 Dave Jones 2003-12-16 09:51:31 EST
Does it work if you boot with acpi=on ?
Comment 6 Need Real Name 2003-12-16 12:26:33 EST
Added acpi=on
Received the following:

Intel Machine check reporting enabled on CPU#0
CPU0:  Intel Pentium III (Cascades) stepping 01
Weird, boot CPU (#15) not listed by the BIOS
booting processor 1/0 eip 3000
APIC never delivered???
Booting processor 1/1 eip 3000
APIC never delivered???
APIC delivery error (ef)
Booting processor 1/2 eip 3000
APIC never delivered???
APIC delivery error (ef)
Booting processor 1/3 eip 3000
APIC never delivered???
APIC delivery error (ef)
ERROR: Only one processor found.
Enabling IO-APIC IRQs

Then the system hangs.  I have to power off and power on to boot.
Comment 7 Felix Miata 2003-12-24 14:17:34 EST
[<c010729d>] kernel_thread_helper [kernel] 0x5 (0xc12cfff0)

Code: 89 b4 84 80 00 00 00 40 89 44 9c 30 46 3b b4 24 a8 05 00 00
<0>Kernel panic: Attempted to kill init

This happens very early after starting install (either plain, or linux
askmethod, or resolution=800x600, or linux mediacheck) from boot.iso
on Plextor wide SCSI CD, after the installer notes that IDE is
disabled on this all LSI 53c875 SCSI system. When trying to install
severn3 on the same system that had rhl9 I got

        install exited abnormally -- received signal 11

right after OK for network IP addressing, I got severn3 to install
from HD instead of NFS, but here I'm already trying HD install.

System is K6/3+ on SiS530 chipset w/ 256M RAM that runs SuSE 8.1, OS/2
and Win98, in addition to Severn3, just fine.

Install from floppy boot instead of boot.iso CD seems to be proceeding
normally.
Comment 8 Felix Miata 2003-12-25 00:55:26 EST
Install proceeded to completion without incident, but the same kernel
panic happened on every successive reboot until I added either noapic
or acpi=on to the kernel line in grub.conf. After updating to the 2135
kernel, neither noapic nor acpi=on were any longer necessary.
Comment 9 Sahil Verma 2004-03-19 01:43:33 EST
This bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.