Bug 1118948 - staypuft-installer no longer working on centos6.5
Summary: staypuft-installer no longer working on centos6.5
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
high
unspecified
Target Milestone: ---
: Installer
Assignee: Marek Hulan
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 06:05 UTC by Antonio C. Velez
Modified: 2014-08-25 07:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-25 07:34:25 UTC


Attachments (Terms of Use)

Description Antonio C. Velez 2014-07-12 06:05:30 UTC
Description of problem:


staypuft no longer working with centos6.5 


Version-Release number of selected component (if applicable):

foreman-installer-1.6.0-0.develop.201407110325git95231b2.el6.noarch
foreman-installer-staypuft-0.1.1-1.el6.noarch
ruby193-rubygem-foreman_discovery-1.3.0-1.el6.noarch
foreman-proxy-1.6.0-0.develop.201407110944gitbbafbc0.el6.noarch
rubygem-foreman_api-0.1.11-1.el6.noarch
foreman-postgresql-1.6.0-0.develop.201407110656gitcb49ec8.el6.noarch
foreman-1.6.0-0.develop.201407110656gitcb49ec8.el6.noarch
ruby193-rubygem-foreman-tasks-0.6.4-1.el6.noarch
foreman-selinux-1.6.0-0.develop.201406261522git5532684.el6.noarch
rubygem-bundler-1.0.15-3.el6.noarch
rubygem-rack-test-0.5.4-1.el6.noarch
rubygem-gssapi-1.1.2-2.el6.noarch
ruby193-rubygem-io-console-0.3-40.1.el6.centos.alt.x86_64
ruby193-rubygem-rake-0.9.2.2-40.1.el6.centos.alt.noarch
ruby193-rubygem-passenger-native-4.0.18-9.5.el6.x86_64
ruby193-rubygem-i18n-0.6.0-3.el6.centos.alt.noarch
ruby193-rubygem-gettext_i18n_rails-0.10.0-3.el6.noarch
ruby193-rubygem-activemodel-3.2.8-2.el6.centos.alt.noarch
ruby193-rubygem-po_to_json-0.0.7-2.el6.noarch
ruby193-rubygem-apipie-params-0.0.3-1.el6.noarch
ruby193-rubygem-rack-cache-1.2-2.el6.centos.alt.noarch
ruby193-rubygem-bootstrap-sass-3.0.3.0-1.el6.noarch
ruby193-rubygem-treetop-1.4.10-6.el6.centos.alt.noarch
ruby193-rubygem-ref-1.0.0-3.el6.centos.alt.noarch
ruby193-rubygem-deep_cloneable-2.0.0-2.el6.noarch
ruby193-rubygem-will_paginate-3.0.2-7.el6.noarch
ruby193-rubygem-sprockets-2.4.5-2.el6.centos.alt.noarch
ruby193-rubygem-journey-1.0.4-2.el6.centos.alt.noarch
ruby193-rubygem-netrc-0.7.7-5.el6.noarch
ruby193-rubygem-railties-3.2.8-3.el6.centos.alt.noarch
ruby193-rubygem-deface-0.7.2-6.el6.noarch
ruby193-rubygem-jquery-ui-rails-4.0.2-7.el6.noarch
ruby193-rubygem-foreman_discovery-1.3.0-1.el6.noarch
ruby193-rubygem-pg-0.12.2-8.el6.x86_64
rubygems-1.3.7-5.el6.noarch
rubygem-mime-types-1.16-3.el6.noarch
rubygem-clamp-0.6.2-2.el6.noarch
rubygem-rest-client-1.6.7-2.el6.noarch
rubygem-powerbar-1.0.11-8.el6.noarch
rubygem-kafo-0.6.4-1.el6.noarch
rubygem-rack-1.1.0-2.el6.noarch
rubygem-thor-0.14.6-2.el6.noarch
rubygem-bundler_ext-0.3.0-6.el6.noarch
rubygem-rubyipmi-0.7.0-2.el6.noarch
rubygem-sinatra-1.0-2.el6.noarch
rubygem-ffi-1.0.9-11.el6.x86_64
rubygem-passenger-4.0.18-9.5.el6.x86_64
rubygem-passenger-native-4.0.18-9.5.el6.x86_64
ruby193-rubygem-rdoc-3.9.5-40.1.el6.centos.alt.x86_64
ruby193-rubygems-1.8.23-40.1.el6.centos.alt.noarch
ruby193-rubygem-rack-1.4.1-5.el6.centos.alt.noarch
ruby193-rubygem-passenger-native-libs-4.0.18-9.5.el6.x86_64
ruby193-rubygem-multi_json-1.8.2-2.el6.noarch
ruby193-rubygem-ruby_parser-3.1.1-5.el6.noarch
ruby193-rubygem-activesupport-3.2.8-4.el6.centos.alt.noarch
ruby193-rubygem-fast_gettext-0.8.0-15.el6.noarch
ruby193-rubygem-uuidtools-2.1.3-3.el6.noarch
ruby193-rubygem-builder-3.0.0-3.el6.centos.alt.noarch
ruby193-rubygem-tilt-1.3.3-10.el6.centos.alt.noarch
ruby193-rubygem-activeresource-3.2.8-2.el6.centos.alt.noarch
ruby193-rubygem-i18n_data-0.2.7-2.el6.noarch
ruby193-rubygem-algebrick-0.4.0-2.el6.noarch
ruby193-rubygem-dynflow-0.7.1-1.el6.noarch
ruby193-rubygem-safemode-1.2.0-5.el6.noarch
ruby193-rubygem-apipie-rails-0.1.2-1.el6.noarch
ruby193-rubygem-sass-3.2.13-1.el6.noarch
ruby193-rubygem-net-ldap-0.3.1-2.el6.noarch
ruby193-rubygem-polyglot-0.3.3-2.el6.centos.alt.noarch
ruby193-rubygem-mail-2.4.4-4.el6.centos.alt.noarch
ruby193-rubygem-audited-3.0.0-2.el6.noarch
ruby193-rubygem-erubis-2.7.0-4.el6.centos.alt.noarch
ruby193-rubygem-sinatra-1.3.2-12.el6.centos.alt.noarch
ruby193-rubygem-ftools-0.0.0-3.el6.noarch
ruby193-rubygem-nokogiri-1.5.11-1.el6.x86_64
ruby193-rubygem-activerecord-3.2.8-8.el6.centos.alt.noarch
ruby193-rubygem-audited-activerecord-3.0.0-2.el6.noarch
ruby193-rubygem-scoped_search-2.7.1-1.el6.noarch
ruby193-rubygem-ancestry-2.0.0-2.el6.noarch
ruby193-rubygem-hike-1.2.1-3.el6.centos.alt.noarch
ruby193-rubygem-oauth-0.4.7-6.el6.noarch
ruby193-rubygem-actionpack-3.2.8-5.5.el6.centos.alt.noarch
ruby193-rubygem-net-http-persistent-2.7-2.el6.centos.alt.noarch
ruby193-rubygem-rest-client-1.6.7-2.el6.noarch
rubygem-json-1.5.5-1.el6.x86_64
rubygem-oauth-0.4.7-6.el6.noarch
rubygem-rdoc-3.12-12.el6.x86_64
rubygem-awesome_print-1.0.2-10.el6.noarch
rubygem-fastercsv-1.5.4-1.el6.noarch
rubygem-netrc-0.7.7-5.el6.noarch
rubygem-foreman_api-0.1.11-1.el6.noarch
rubygem-hashie-2.0.5-1.el6.noarch
rubygem-multi_json-1.8.2-2.el6.noarch
rubygem-logging-1.8.1-26.el6.noarch
ruby193-rubygem-thor-0.15.4-2.el6.centos.alt.noarch
ruby193-rubygem-jquery-rails-2.0.2-2.el6.centos.alt.noarch
ruby193-rubygem-rails-3.2.8-2.el6.centos.alt.noarch
ruby193-rubygem-wicked-1.0.2-3.el6.noarch
ruby193-rubygem-bundler_ext-0.3.0-6.el6.noarch
ruby193-rubygem-sequel-3.45.0-4.el6.noarch
ruby193-rubygem-staypuft-0.1.9-1.el6.noarch
rubygem-kafo_parsers-0.0.3-1.el6.noarch
rubygem-rkerberos-0.1.3-2.1.el6.x86_64
rubygem-rake-0.8.7-2.1.el6.noarch
rubygem-passenger-native-libs-4.0.18-9.5.el6.x86_64
ruby193-rubygem-bigdecimal-1.1.0-40.1.el6.centos.alt.x86_64
ruby193-rubygem-passenger-4.0.18-9.5.el6.x86_64
ruby193-rubygem-sexp_processor-4.1.3-4.el6.noarch
ruby193-rubygem-json-1.5.5-40.1.el6.centos.alt.x86_64
ruby193-rubygem-mime-types-1.19-1.el6.centos.alt.noarch
ruby193-rubygem-rabl-0.9.0-1.el6.noarch
ruby193-rubygem-ruby2ruby-2.0.1-7.el6.noarch
ruby193-rubygem-daemons-1.1.4-7.el6.noarch
ruby193-rubygem-arel-3.0.2-3.el6.centos.alt.noarch
ruby193-rubygem-rack-test-0.6.1-3.el6.centos.alt.noarch
ruby193-rubygem-rack-protection-1.2.0-7.el6.centos.alt.noarch
ruby193-rubygem-therubyracer-0.11.0-0.6.beta5.el6.centos.alt.x86_64
ruby193-rubygem-tzinfo-0.3.33-2.el6.centos.alt.noarch
ruby193-rubygem-foreigner-1.4.2-1.el6.noarch
ruby193-rubygem-open4-1.3.0-8.el6.noarch
ruby193-rubygem-rack-ssl-1.3.2-7.el6.centos.alt.noarch
ruby193-rubygem-actionmailer-3.2.8-1.el6.centos.alt.noarch
ruby193-rubygem-diff-lcs-1.1.3-1.el6.centos.alt.noarch
ruby193-rubygem-bundler-1.1.4-3.el6.centos.alt.noarch
ruby193-rubygem-gettext_i18n_rails_js-0.0.8-2.el6.noarch
ruby193-rubygem-foreman-tasks-0.6.4-1.el6.noarch
rubygem-highline-1.6.21-2.el6.noarch
rubygem-ansi-1.4.3-2.el6.noarch
rubygem-apipie-bindings-0.0.8-2.el6.noarch
rubygem-little-plugger-1.1.3-18.el6.noarch



How reproducible:

install the following repos:

rpm -ivh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh http://repos.fedorapeople.org/repos/openstack/openstack-icehouse/epel-6/rdo-release-icehouse-3.noarch.rpm
wget http://dev.centos.org/centos/6/SCL/scl.repo -O /etc/yum.repos.d/scl.repo

cat >> /etc/yum.repos.d/foreman-nightly.repo << "EOF"
[foreman-nightly]
name=foreman-nightly
baseurl=http://yum.theforeman.org/nightly/el6/x86_64/
enable=1
gpgcheck=0
EOF

cat >> /etc/yum.repos.d/foreman-plugins-nightly.repo << "EOF"
[foreman-plugins-nightly]
name=foreman-plugins-nightly
baseurl=http://yum.theforeman.org/plugins/nightly/el6/x86_64/
enable=1
gpgcheck=0
EOF


then install staypuft:

yum install foreman-installer-staypuft -y

Actual results:

Error Starting configuration...
Warning: Sections other than main, master, agent, user are deprecated in puppet.conf. Please use the directory environments feature to specify environments. (See http://docs.puppetlabs.com/puppet/latest/reference/environments.html)
   (at /usr/lib/ruby/site_ruby/1.8/puppet/settings/config_file.rb:77:in `collect')
Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Error 400 on SERVER: Failed to find staypuft.example.com via exec: Execution of '/etc/puppet/node.rb staypuft.example.com' returned 1: 
/usr/share/foreman-installer/hooks/lib/base_seeder.rb:28:in `find_default_os': undefined method `[]' for nil:NilClass (NoMethodError)
	from /usr/share/foreman-installer/hooks/lib/subscription_seeder.rb:17:in `initialize'
	from /usr/share/foreman-installer/hooks/post/10-setup_provisioning.rb:24:in `new'
	from /usr/share/foreman-installer/hooks/post/10-setup_provisioning.rb:24:in `load'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `instance_exec'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:48:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `each_pair'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:339:in `run_installation'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `call'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `exit'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:122:in `exit'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:338:in `run_installation'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:109:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
	from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/staypuft-installer:54

Comment 4 Marek Hulan 2014-08-07 08:48:44 UTC
It seems that installation itself did not finish completely so configuration failed. I'd suggest testing with latest foreman-staypuft-installer and uploading the full log of installer (to be found at /var/log/foreman-installer/)

Comment 5 Marek Hulan 2014-08-21 09:19:13 UTC
I'm unable to reproduce with latest version, in fact I'm able to install on CentOS 6.5 with nightly packages. Please reopen if you have a reproducer.

Comment 6 Antonio C. Velez 2014-08-24 05:56:02 UTC
I use the same procedure as before and then I got this new error:

[root@staypuft ~]# staypuft-installer --foreman-repo=nightly --color-of-background bright
Networking setup:
       Network interface: 'eth0'
              IP address: '10.55.0.100'
            Network mask: '255.255.255.0'
         Network address: '10.55.0.0'
            Host Gateway: '10.55.0.1'
        DHCP range start: '10.55.0.101'
          DHCP range end: '10.55.0.254'
            DHCP Gateway: '10.55.0.100'
           DNS forwarder: '4.2.2.1'
                  Domain: 'example.com'
             Foreman URL: 'https://staypuft.example.com'
           NTP sync host: '1.centos.pool.ntp.org'
Configure networking on this machine: ✓
Configure firewall on this machine: ✓

The installer can configure the networking and firewall rules on this machine with the above configuration. Default values are populated from the this machine's existing networking configuration.

If you DO NOT want to configure networking please set 'Configure networking on this machine' to No before proceeding. Do this by selecting option 'Do not configure networking' from the list below.

How would you like to proceed?:
1. Proceed with the above values
2. Change Network interface
3. Change IP address
4. Change Network mask
5. Change Network address
6. Change Host Gateway
7. Change DHCP range start
8. Change DHCP range end
9. Change DHCP Gateway
10. Change DNS forwarder
11. Change Domain
12. Change Foreman URL
13. Change NTP sync host
14. Do not configure networking
15. Do not configure firewall
16. Cancel Installation
1
Configure client authentication
          SSH public key: ''
           Root password: '*******************************************'

Please set a default root password for newly provisioned machines. If you choose not to set a password, it will be generated randomly. The password must be a minimum of 8 characters. You can also set a public ssh key which will be deployed to newly provisioned machines.

How would you like to proceed?:
1. Proceed with the above values
2. Change SSH public key
3. Change Root password
4. Toggle Root password visibility
1
Starting networking setup
Networking setup has finished
Installing             Done                                               [100%] [..................................................................]
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': /usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:56: syntax error, unexpected tIDENTIFIER, expecting '}' (SyntaxError)
...g_template.show_or_ensure({'id' => 'Kickstart default'},
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:56: syntax error, unexpected tCONSTANT, expecting kEND
..._or_ensure({'id' => 'Kickstart default'},
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:57: syntax error, unexpected tIDENTIFIER, expecting kEND
...                    {'template' => kickstart_default, 'templ...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:57: syntax error, unexpected tIDENTIFIER, expecting kEND
...art_default, 'template_kind_id' => provisioning['id'], 'name...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:57: syntax error, unexpected tIDENTIFIER, expecting kEND
...e_kind_id' => provisioning['id'], 'name' => 'Kickstart defau...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:57: syntax error, unexpected tIDENTIFIER, expecting kEND
...' => provisioning['id'], 'name' => 'Kickstart default'})
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:57: syntax error, unexpected tCONSTANT, expecting kEND
...ng['id'], 'name' => 'Kickstart default'})
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:58: syntax error, unexpected tIDENTIFIER, expecting kEND
...g_template.show_or_ensure({'id' => 'Kickstart default PXELin...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:58: syntax error, unexpected tCONSTANT, expecting kEND
..._or_ensure({'id' => 'Kickstart default PXELinux'},
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:59: syntax error, unexpected tIDENTIFIER, expecting kEND
...                    {'template' => kickstart_default_pxelinu...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:59: syntax error, unexpected tIDENTIFIER, expecting kEND
...lt_pxelinux, 'template_kind_id' => pxe_linux['id'], 'name' =...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:59: syntax error, unexpected tIDENTIFIER, expecting kEND
...late_kind_id' => pxe_linux['id'], 'name' => 'Kickstart defau...
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:59: syntax error, unexpected tIDENTIFIER, expecting kEND
..._id' => pxe_linux['id'], 'name' => 'Kickstart default P
                              ^
/usr/share/foreman-installer/hooks/lib/provisioning_seeder.rb:59: syntax error, unexpected tCONSTANT, expecting kEND
...ux['id'], 'name' => 'Kickstart default P
                              ^
	from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
	from /usr/share/foreman-installer/hooks/post/10-setup_provisioning.rb:4:in `load'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `instance_exec'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hook_context.rb:13:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:48:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `each_pair'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/hooking.rb:47:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:339:in `run_installation'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `call'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/exit_handler.rb:24:in `exit'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:122:in `exit'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:338:in `run_installation'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:109:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:68:in `run'
	from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:126:in `run'
	from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/staypuft-installer:55

Comment 8 Marek Hulan 2014-08-25 07:34:25 UTC
Please open separate BZs for different issues. The mentioned PR was merged and fix is released in 0.3.3. Reverting status to closed.


Note You need to log in before you can comment on or make changes to this bug.