Bug 1118971 - firefox in full screen video flickers
Summary: firefox in full screen video flickers
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 14:11 UTC by cornel panceac
Modified: 2014-12-23 10:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-23 10:20:47 UTC


Attachments (Terms of Use)

Description cornel panceac 2014-07-12 14:11:07 UTC
Description of problem:
if you switch a flash video to fullscreen, firefox/flash fights with gnome-shell to take control of the screen. from time to time, video screen gets white and the gnome-shell bar show up on top of the screen. filckering happens once per second or so.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 cornel panceac 2014-07-12 17:28:58 UTC
the videocard is:


$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)


but, same youtube (for example, but not only) videolink, played in vlc has no problem with full screen. also, same video played NOT in full screen , works fine.

Comment 2 cornel panceac 2014-08-29 19:35:09 UTC
i've found that in gnome-wayland, this is not happening. eventually i understood why: because the shell (top bar) is always on top, even if the flash video is full screen. (unlike regular gnome where the full screen video always fights with the shell (top bar?) for who will be on top).

Comment 3 Martin Stransky 2014-12-22 16:29:15 UTC
Okay, moving to gnome-shell.

Comment 4 cornel panceac 2014-12-23 10:20:47 UTC
ok, this is no longer happening in gnome-shell too, so i will close it.


Note You need to log in before you can comment on or make changes to this bug.