Bug 1118975 - Bogus error on aarch64: Error: The location 128 is outside of the device /dev/...
Summary: Bogus error on aarch64: Error: The location 128 is outside of the device /dev...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: parted
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-12 15:26 UTC by Richard W.M. Jones
Modified: 2014-07-12 15:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-12 15:26:55 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-07-12 15:26:05 UTC
Description of problem:

With a 100MB block device:

$ sudo blockdev --getsize64 /dev/vg_data/tmp
104857600
$ sudo parted -s -- /dev/vg_data/tmp mklabel msdos mkpart primary 128 -128s 
Error: The location 128 is outside of the device /dev/dm-2.

If the size of the block device is increased a bit to 500 MB, then
the same command works fine:

$ sudo blockdev --getsize64 /dev/vg_data/tmp524288000
$ sudo parted -s -- /dev/vg_data/tmp mklabel msdos mkpart primary 128 -128s 
Warning: The resulting partition is not properly aligned for best performance.
$ echo $?
0

Version-Release number of selected component (if applicable):

parted-3.1-28.fc21.aarch64

Also tested parted-3.1-17.sa1.4.aarch64 which fails in the same way.

How reproducible:

100%

Steps to Reproduce:
1. See above.
2.
3.

Comment 1 Richard W.M. Jones 2014-07-12 15:26:55 UTC
OK, I see why this is not a bug.  I omitted '128s' ...


Note You need to log in before you can comment on or make changes to this bug.