Bug 1119019 - Remove network with network custom properties from Host fails
Summary: Remove network with network custom properties from Host fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: GenadiC
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-13 07:51 UTC by GenadiC
Modified: 2016-02-10 19:36 UTC (History)
5 users (show)

Fixed In Version: ovirt-3.5.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:40:13 UTC
oVirt Team: Network


Attachments (Terms of Use)
engine and vdsm logs (2.03 MB, application/zip)
2014-07-13 07:51 UTC, GenadiC
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30108 master MERGED webadmin: Allow custom properties on NIC without network Never
oVirt gerrit 30494 ovirt-engine-3.5 MERGED engine: Allow custom properties on NIC without network Never
oVirt gerrit 30496 master MERGED webadmin: Reset properties when detaching network Never
oVirt gerrit 30500 ovirt-engine-3.5 MERGED webadmin: Reset properties when detaching network Never

Description GenadiC 2014-07-13 07:51:53 UTC
Created attachment 917599 [details]
engine and vdsm logs

Description of problem:
Got "CanDoAction of action SetupNetworks failed. Reasons:VAR__ACTION__SETUP,VAR__TYPE__NETWORKS,ACTION_TYPE_FAILED_NETWORK_CUSTOM_PROPERTIES_NO_NETWORK,$ACTION_TYPE_FAILED_NETWORK_CUSTOM_PROPERTIES_NO_NETWORK_LIST eth2" when trying to remove network from Host with setupNetworks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create network on DC/Cluster/Host
2. Configure ethtool_opts on that network with some "kuku" value
3. Try to remove the network from Host with SN

Actual results:
Action fails with CanDoAction

Expected results:
Action should succeed

Additional info:
After removing ethtool_opts the SN action succeeded

Comment 1 GenadiC 2014-07-20 13:40:05 UTC
Another scenario:
1) Remove network (with network custom properties) from Host using Rest API - action will succeed
2) Opening SetupNetworks in GUI and clicking ok button will fail because of network custom properties
3) Map any network on the NIC (from which the network with network custom properties was removed)

Result: There is a configuration of network custom properties for that NIC

Expected result:
New network should be mapped without any configuration of custom properties and clicking on ok in setupNetwork window should succeed

Comment 2 Lior Vernia 2014-07-20 13:50:17 UTC
Interesting! While my first patch addresses article (2), I'll push a separate GUI patch to fix (3).

Comment 3 Lior Vernia 2014-07-21 07:22:59 UTC
Merged patch solved the worst part of the bug, removing blocker status.

Comment 4 GenadiC 2014-07-24 08:09:21 UTC
Verified in 3.5.0-0.0.master.20140722232058.git8e1babc.el6

Comment 5 Sandro Bonazzola 2014-10-17 12:40:13 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.