Bug 1119066 - nouveau: Fails to resume from suspend an NV84 since 3.15.3+
Summary: nouveau: Fails to resume from suspend an NV84 since 3.15.3+
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-13 16:57 UTC by Nicolas Dufresne
Modified: 2015-05-13 14:10 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-13 14:10:24 UTC


Attachments (Terms of Use)
Kernel trace I have managed to capture (7.11 KB, text/plain)
2014-07-13 16:57 UTC, Nicolas Dufresne
no flags Details
dmesg dump after pm-suspend (136.77 KB, text/plain)
2014-07-17 21:41 UTC, Luke
no flags Details
/var/log/messages when suspending to RAM (sleep) (3.74 KB, text/plain)
2014-07-20 19:58 UTC, Luke
no flags Details
/var/log/messages when waking from sleep, unsuccessfully (30.58 KB, text/plain)
2014-07-20 20:00 UTC, Luke
no flags Details
journalctl -b dump with unsuccessful boot (191.54 KB, text/x-vhdl)
2014-11-10 17:14 UTC, Luke
no flags Details
Xorg.0.log showing unsuccessful boot into graphical mode (3.16.6 and 3.16.7 kernel versions) (8.39 KB, text/plain)
2014-11-10 17:17 UTC, Luke
no flags Details

Description Nicolas Dufresne 2014-07-13 16:57:48 UTC
Created attachment 917637 [details]
Kernel trace I have managed to capture

Description of problem:
Since 3.15.3 (same on 3.15.4), nouveau driver fails to resume from suspend on a NV84 Core (as found on Macbook Pro 2008).


Version-Release number of selected component (if applicable):
3.15.3 and 3.15.4


How reproducible:
Always

Steps to Reproduce:
1. Boot and log into Gnome Shell
2. Flip the LID to suspent
3. Open the LID

Actual results:
Garbled screen, caps lock key not responding, VT switching not working. 


Expected results:
Back to shell unlock screen.


Additional info:
This is a regression from 3.14.9. I'm not sure the attach trace is what is needed to debug this issue. Instructions to betters traces are welcome.

Comment 1 Luke 2014-07-17 21:41:25 UTC
Created attachment 918838 [details]
dmesg dump after pm-suspend

Comment 2 Luke 2014-07-17 21:43:59 UTC
Same problem here, with 3.15.5 kernel, MacBook Pro A1260 with fresh and only Fedora 20 EFI installation.

3.14- kernels worked fine, with rare occurrences of the garbled screen reported above.

Hibernate, however, still works fine. Attached dmesg dump as suggested in

http://fedoraproject.org/wiki/Common_kernel_problems#Suspend.2FResume_failure

Comment 3 Luke 2014-07-20 19:58:30 UTC
Created attachment 919474 [details]
/var/log/messages when suspending to RAM (sleep)

Same problem still with 3.15.6-200.fc20.x86_64, I attach /var/log/messages when suspending to RAM and when waking (below).

Comment 4 Luke 2014-07-20 20:00:48 UTC
Created attachment 919475 [details]
/var/log/messages when waking from sleep, unsuccessfully

I attach /var/log/messages when waking from sleep, before a forced reboot. This part of log is not registered in the journal.

Comment 5 Nicolas Dufresne 2014-11-08 19:07:28 UTC
Any info here ? passed 3.16.2, things got really worst, and Xorg don't start anymore.

Comment 6 Luke 2014-11-10 17:14:52 UTC
Created attachment 955898 [details]
journalctl -b dump with unsuccessful boot

Indeed, with 3.16.6 and 3.16.7 the system fails to boot into a graphical mode altogether.
I attach journactl -f dump with such a boot.

Comment 7 Luke 2014-11-10 17:17:42 UTC
Created attachment 955901 [details]
Xorg.0.log showing unsuccessful boot into graphical mode (3.16.6 and 3.16.7 kernel versions)

Also attached is Xorg.0.log when running startx upon logging with CTRL+F2.

For now, I put the no-delete flag to 3.16.4 kernel version and I stick to that. This is getting really serious.

Comment 8 Nicolas Dufresne 2014-11-10 21:24:39 UTC
I've created a seperated bug for the "no graphical boot" as per a discussion on #nouveau, these are two bugs, See bug #1161887. The report include a hacky workaround.

Comment 9 Nicolas Dufresne 2015-05-13 14:10:24 UTC
Return from suspend works again now on F22 (kernel 4.0.1+). I mostly tested on gnome-wayland to be honnest, but it worked when I took the time to force X to start. bug #1161887 is still there.


Note You need to log in before you can comment on or make changes to this bug.