Bug 1119094 - RFE: multi-file upload modal can be closed and re-opened, with continued uploading
Summary: RFE: multi-file upload modal can be closed and re-opened, with continued uplo...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Usability
Version: development
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michelle Kim
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 00:55 UTC by David Mason
Modified: 2015-07-29 02:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 02:12:03 UTC


Attachments (Terms of Use)

Description David Mason 2014-07-14 00:55:00 UTC
Description of problem:
When source documents are uploading, a user can attempt to close the upload dialog by clicking outside it, clicking 'cancel' or clicking the X at the top right. Attempts to close the upload dialog cause a warning to be displayed, for the user to confirm canceling the upload.

Usability would be better if the user could close the dialog with no warning and have files continue to upload. Summary upload progress could be shown in a widget, and the user could re-open the upload dialog to see the detailed progress information.

A warning would generally still be necessary when closing the page due to technical limitations: the file selector elements that are necessary to upload (due to browser permissions) would be reset, and could not return to their previous state without user intervention.


Steps to Reproduce:

1. Navigate to document settings in a version for which you have file upload permission.
2. Open the source document upload dialog.
3. Input one or more documents, of sufficient size to allow some clicks before upload completes.
4. Click 'Upload Documents'.
5. Before upload completes, close the dialog by clicking any of:
  - the 'X' at the top right of the dialog
  - the background outside the modal
6. Re-open the source document upload dialog.

Actual results:
5. A modal warning is displayed asking for confirmation to cancel the upload.
6. The dialog opens and is in the default state with no files.

Expected results:
5. The dialog is closed, a widget shows that upload is occurring and updates regularly to indicate the ongoing progress of the upload. The widget is grouped with the  that opens the source document upload dialog.
6. The dialog opens and shows the continuing progress of file upload as though it had not been closed.

The 'Cancel' button should still stop the upload, but should cause a widget to be shown that indicates that the upload is stopped, and that offers a 'resume' operation.

Additional info:
http://alistapart.com/article/neveruseawarning

Comment 1 Ding-Yi Chen 2014-07-24 05:34:55 UTC
How do you handle following cases:

1. User wants to continue upload, but accidentally click the "close" button
2. User wants to continue upload at background.
3. User wants to cancel the upload.


I don't really think that it should close the dialog just bu clicking outside it.

Comment 2 David Mason 2014-07-27 22:57:26 UTC
(In reply to Ding-Yi Chen from comment #1)
> How do you handle following cases:
> 
> 1. User wants to continue upload, but accidentally click the "close" button
> 2. User wants to continue upload at background.

These two are the whole point of this RFE - I think this is covered adequately in the initial description above, and I would just be repeating that if I try to address these. In short, the dialog could be closed and there would be a progress bar on the page behind it.

> 3. User wants to cancel the upload.

They click the cancel button on the dialog (or next to the progress bar if the dialog is closed), then confirm that they really want to cancel the upload.


> I don't really think that it should close the dialog just bu clicking
> outside it.

That is the standard behaviour for modal dialogs across Zanata at the moment. I think it should be consistent with the rest of Zanata so that users have a consistent and predictable experience.

Comment 4 Damian Jansen 2015-07-14 00:21:49 UTC
Reassigned to PM

Comment 5 Zanata Migrator 2015-07-29 02:12:03 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-152


Note You need to log in before you can comment on or make changes to this bug.