Bug 1119300 - [RFE] allow easy add copr repos in using repository list
Summary: [RFE] allow easy add copr repos in using repository list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Valentin Gologuzov
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-14 13:13 UTC by Igor Gnatenko
Modified: 2015-12-01 06:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 16:16:01 UTC


Attachments (Terms of Use)

Description Igor Gnatenko 2014-07-14 13:13:35 UTC
For example:
http://copr.fedoraproject.org/coprs/ignatenkobrain/neovim/edit/

If we will add there 'sgallagh/nodejs-0.12' It will atomatically add copr repo to chroot.

That's general idea of this bug.

Comment 1 Tomáš Hozza 🤓 2014-08-26 13:56:35 UTC
+1 for this request.

Now I have to copy the URLs from repo files manually. If I built for released/branched Fedoras and rawhide, I have to copy two URLs for each copr project I'm depending on.

Comment 2 Valentin Gologuzov 2015-02-18 15:11:56 UTC
Added new functionality in the commit e8656920da.
Now you can reference Copr repo using "copr://" schema. I.e. to include 'sgallagh/nodejs-0.12' - add 'copr://sgallagh/nodejs-0.12' to the Repos field at /edit/ subpage.
Deployed to the dev server.

Comment 3 Valentin Gologuzov 2015-02-18 15:18:35 UTC
*** Bug 1091640 has been marked as a duplicate of this bug. ***

Comment 4 Pavel Raiskup 2015-02-18 16:17:04 UTC
Thanks for this fix.  Perfect!

(In reply to Valentin Gologuzov from comment #2)
> Added new functionality in the commit e8656920da.

Btw. the commit should be probably 05490376d9cf.

> Now you can reference Copr repo using "copr://" schema. I.e. to include
> 'sgallagh/nodejs-0.12' - add 'copr://sgallagh/nodejs-0.12' to the Repos
> field at /edit/ subpage.
> Deployed to the dev server.

Just a nit, it would be very nice if we could consider cross copr instance
referencing.  E.g. reference Fedora Copr repository from lets say company
internal one?  Probably the syntaxe could be copr://local/user/ ?  Just to let
there a space for future improvements?

Comment 5 Valentin Gologuzov 2015-02-18 22:12:03 UTC
I would prefer to avoid adding more logic to "copr://" schema. So either somebody also express interest in this feature or let's move to #1091640 and discuss required expand variables there.

Comment 6 Valentin Gologuzov 2015-03-05 16:16:01 UTC
Deployed into the fedora cloud
Version:
 copr-backend  1.58-1
 copr-frontend 1.55-1


Note You need to log in before you can comment on or make changes to this bug.